NCTAudioTransform2Lib

NCTAudioStudio2 ActiveX DLLs
NCTAudioTransform2 ActiveX DLL

Version 2.2

NCTAudioTransform2 ActiveX DLL is intended for processing and transforming of audio data.

With NCTAudioTransform2 you can perform the following operations:

  • Amplify audio data

  • Insert time delay in audio array

  • Modulate audio array

  • Invert audio array

  • Reverse audio array

  • Mix two audio arrays

  • Perform FFT transform

  • Generate sine or noise array

  • Normalize audio data

  • Filter audio data

  • Equalize audio data

  • Delete silence from audio array

  • Resample audio array

and many other...

NCTAudioTransform2 consists of the following objects:

  • AudioTransform2 - the main object for transforming.

  • AudioTransformDisplay2 - a complementary object for visual representation of creating the FFTArray array for FFTFilter method from the main object.

NCTAudioTransform2 is a part of the NCTAudioStudio2 package.

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


NCTAudioTransform2 objects

NCTAudioTransform2 objects

Object | Description
AudioTransform2 | AudioTransform2 object is intended for processing and transforming of audio data.
AudioTransformDisplay2 | AudioTransformDisplay2 object is intended for visual representation of creating the FFTArray array for FFTFilter method.

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


AudioTransform2

AudioTransform2 object

AudioTransform2 object is intended for processing and transforming of audio data.

This object contains the following methods and properties for audio data transforming using:

  • filters (BandPassFilter, FFTFilter, HighPassFilter, HighShelfFilter, LowPassFilter, LowShelfFilter, NotchFilter, PeakEQFilter);

  • delays (Delay, Phaser, Flanger, Reverb, Chorus);

  • amplitude changing (Invert, Reverse, Silence, Amplify, Normalize, Fade, Vibrato, Compressor, Expander);

  • equalizer (Equalizer);

  • other (Resample, AddNoise, Envelope, MixArrays, DeleteSilence, MixStereoChannels, TrimLeft, TrimRight, PitchShift, TimeStretch).

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


AudioTransform2 properties

AudioTransform2 properties

Property | Type | Default | Description
ArrayChannels | ChannelsConstants |  | Gets or sets the number of channels of the audio array. Monaural data uses one channel and stereo data uses two channels.
ArrayFrequency | FrequencyConstants |  | Gets or sets the frequency of the audio array.
LastErrorNum | ErrorConstants |  | Read-only property that returns the number of the last error.
SmoothLeftEnabled | Boolean |  | Gets or sets a flag indicating if smoothing is enabled or not at the starting position of the audio array.
SmoothRightEnabled | Boolean |  | Gets or sets a flag indicating if smoothing is enabled or not at the ending position of the audio array.
SmoothTime | Long |  | Gets or sets the time of smoothing.
TBEventEnabled | Boolean |  | Gets or sets a flag indicating if TransformBlock event is enabled or not.


ArrayChannels property (AudioTransform2 object)

ArrayChannels property (AudioTransform2 object)

Gets or sets the number of channels of the audio array. Monaural data uses one channel and stereo data uses two channels.

Property type

A ChannelsConstants value.

Syntax

object.ArrayChannels [= value]

The ArrayChannels property syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
value | ChannelsConstants | Number of channels.

See Also:

ArrayFrequency

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


ArrayFrequency property (AudioTransform2 object)

ArrayFrequency property (AudioTransform2 object)

Gets or sets the frequency of the audio array.

Property type

A FrequencyConstants value.

Syntax

object.ArrayFrequency [= value]

The ArrayFrequency property syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
value | FrequencyConstants | Frequency value.

See Also:

ArrayChannels

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


LastErrorNum property (AudioTransform2 object)

LastErrorNum property (AudioTransform2 object)

Read-only property that returns the number of the last error.

Property type

An ErrorConstants value.

Syntax

object.LastErrorNum [= value]

The LastErrorNum property syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
value | ErrorConstants | The type of error.

Remarks:

At present you can use two ways for an errors catch: using the standard error processor from VB or using the LastErrorNum property.

See Also:

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


SmoothLeftEnabled property (AudioTransform2 object)

SmoothLeftEnabled property (AudioTransform2 object)

Gets or sets a flag indicating if smoothing is enabled or not at the starting position of the audio array.

Property type

A Boolean value.

Syntax

object.SmoothLeftEnabled [= value]

The SmoothLeftEnabled property syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
value | Boolean | True if smoothing is enabled, otherwise - False.

See Also:

SmoothRightEnabled | SmoothTime

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


SmoothRightEnabled property (AudioTransform2 object)

SmoothRightEnabled property (AudioTransform2 object)

Gets or sets a flag indicating if smoothing is enabled or not at the ending position of the audio array.

Property type

A Boolean value.

Syntax

object.SmoothRightEnabled [= value]

The SmoothRightEnabled property syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
value | Boolean | True if smoothing is enabled, otherwise - False.

See Also:

SmoothLeftEnabled | SmoothTime

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


SmoothTime property (AudioTransform2 object)

SmoothTime property (AudioTransform2 object)

Gets or sets the time of smoothing.

Property type

A Long value.

Syntax

object.SmoothTime [= value]

The SmoothTime property syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
value | Long | Time of smoothing, in ms. By default this value is set to 50 milliseconds.

See Also:

SmoothLeftEnabled | SmoothRightEnabled

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


TBEventEnabled property (AudioTransform2 object)

TBEventEnabled property (AudioTransform2 object)

Gets or sets a flag indicating if TransformBlock event is enabled or not.

Property type

A Boolean value.

Syntax

object.TBEventEnabled [= value]

The TBEventEnabled property syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
value | Boolean | True if TransformBlock event is enabled, otherwise - False.

See Also:

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


AudioTransform2 methods

AudioTransform2 methods

Method | Description
AddNoise | Adds noise to the audio data array.
Amplify | Changes the amplitude of the existing audio data array.
BandPassFilter | Applies a Band Pass filter to the existing audio data array.
CancelTransform | Cancels process of transformation of audio data array
Chorus | Applies chorus effect to the existing audio data array.
Compressor | Reduces the dynamic range of the signal.
DBToPercent | Converts value from db to percents.
Delay | Applies delay effect to the existing audio data array.
DeleteSilence | Deletes silence from the existing audio data array.
DuplicateArray | Duplicates audio data array.
Envelope | Gives you control over what parts of the audio data array are amplified or inverted (negative values), and by how much according to the data in EnvelopeArray. This method allows to set individual amplification factors for every individual sample in the audio data array.
Equalizer | Applies equalizing to the existing audio data array.
Expander | Adds expander effect to the audio data array. The expander is essentially an amplifier with a variable gain control.
Fade | Creates a fading in (soft to loud) or fading out (loud to soft) effect in the existing audio data array. The audio data will be linearly faded from starting magnitude AmplifyLeft to ending magnitude AmplifyRight.
FFTFilter | Applies Fast Fourier filter to the existing audio data array.
FFTPhase | Applies the Fast Fourier transformation to the input audio array and returns an array of phase coefficients.
FFTPower | Applies the Fast Fourier transformation to the input audio array and returns an array of power coefficients.
FIRFilter | Applies Finite Impulse Response filter to the existing audio data array.
Flanger | Applies flanging effect to the existing audio data array.
GetLeftStereoChannel | Gets audio data array of the left stereo channel from the existing audio data array.
GetRightStereoChannel | Gets audio data array of the right stereo channel from the existing audio data array.
HighPassFilter | Applies High Pass filter to the existing audio data array.
HighShelfFilter | Applies High Shelf filter (treble control) to the existing audio data array.
Invert | Inverts the existing audio data array.
LowPassFilter | Applies Low Pass filter to the existing audio data array.
LowShelfFilter | Applies Low Shelf filter (bass control) to the existing audio data array.
MakeMonoFromStereo | Makes mono audio data array from stereo audio data array.
MakeStereoFromArrays | Makes stereo audio data array from separate left and right channels audio data arrays.
MakeStereoFromMono | Makes stereo audio data array from mono audio data array.
MixArrays | Creates output audio data array by mixing two input audio data arrays.
MixStereoChannels | Mixes stereo channels in audio data array.
Normalize | Normalizes the existing audio data array.
NotchFilter | Applies Notch filter to the existing audio data array.
PeakEQFilter | Applies Peak EQ filter to the existing audio data array.
PercentToDB | Converts value from percents to db.
Phaser | Applies phasing effect to the existing audio data array.
PitchShift | Changes the frequency of the audio file.
Register | Enters user name and registration password to disable About window.
Resample | Decreases or increases the rate of the existing audio data array.
Reverb | Reverberates the existing audio data array.
Reverse | Reverses the existing audio data array.
Silence | Inserts silence in the existing audio data array.
TimeStretch | Stretches an audio array by time.
TrimLeft | Trims the existing audio data array from the beginning, deleting silence.
TrimRight | Trims the existing audio data array from the finish, deleting silence.
Vibrato | Applies Vibrato effect to the existing audio data array.


AddNoise method

AddNoise method

Adds noise to the audio data array.

Syntax

object.AddNoise(WavArray As Integer(), dbNoiseLevel As float, NoiseType As Long)

The AddNoise method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.
dbNoiseLevel | float | Amplitude of noise signal, from -92 db to 0.
NoiseType | Long | The noise type. 1 - white noise, 2 - Gaussian noise.

Remarks:

The dbNoiseLevel = -92 is equal to the least noisy signal, dbNoiseLevel = 0 is equal to the most noisy signal.

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.AddNoise LChannel(), -50, 1
AudioTransform21.AddNoise RChannel(), -50, 2
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | Invert | Normalize | Phaser | Resample | Reverb | Reverse | Silence | TrimLeft | TrimRight | Vibrato

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


Amplify method

Amplify method

Changes the amplitude of the existing audio data array.

Syntax

object.Amplify(WavArray As Integer(), Amp As float)

The Amplify method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.
Amp | float | Amplification coefficient in percents. If Amp = 100, then audio array isn't changed. If Amplify > 100 then Volume of audio is increased, otherwise it is decreased.

Remarks:

The method doesn't change amplitude at the first and last position of the audio array, if property SmoothLeftEnabled (SmoothRightEnabled) is set to True.

For converting Amplification coefficient from db to percents you can use DBToPercent method.

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.Amplify LChannel(), AudioTransform21.DBToPercent 10
AudioTransform21.Amplify RChannel(), AudioTransform21.DBToPercent 10
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

AddNoise | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | Invert | Normalize | Phaser | Resample | Reverb | Reverse | Silence | TrimLeft | TrimRight | Vibrato

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


BandPassFilter method

BandPassFilter method

Applies a Band Pass filter to the existing audio data array.

Syntax

object.BandPassFilter(WavArray As Integer(), Frequency As float, Steepness As float)

The BandPassFilter method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.
Frequency | float | Central frequency of the filter, in Hertz.
Steepness | float | Steepness of the filter, from 0.01 to 100.

Remarks:

The Band Pass filter consists of a Low Pass and a High Pass combined together, so it allows the frequencies falling within a certain range. The Band Pass filter will act like a Low Pass and a High Pass together: it will pass only the frequencies falling within a certain range.

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

For more information about Band Pass filter effect see: FiltersInformation

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.BandPassFilter LChannel(), 800, 50
AudioTransform21.BandPassFilter RChannel(), 800, 50
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

FFTFilter | HighPassFilter | HighShelfFilter | LowPassFilter | LowShelfFilter | NotchFilter | PeakEQFilter

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


CancelTransform method

CancelTransform method

Cancels process of transformation of audio data array.

Syntax

object.CancelTransform

The CancelTransform method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.

See Also:

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


Chorus method

NCTAudioCompress ActiveX DLL
Chorus method (AudioTransform2 object)

Applies chorus effect to the existing audio data array.

Syntax

object.Chorus(WavArray As Integer(), DelayRate As float, MixDepth As float, FeedBackGain As float, SweepDepth As float, SweepRate As float, SweepPhase As float)

The Chorus method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.
DelayRate | float | Rate of delay. Varies from 0 (no delay) to 100 (20 ms delay).
MixDepth | float | The dry is the volume of the input signal and the wet is the volume of the delayed signal, in percent. Varies from 0 to 100. If MixDepth = 0 the resulting signal does not contain delayed signal. If MixDepth = 100 the resulting signal does not contain input signal. Other values of MixDepth are a combination of the dry and the wet (wet = 100 - dry).
FeedBackGain | float | FeedBackGain sets how much delay is fed back to the input. Varies from 0 to 100.
SweepDepth | float | The sweep depth determines how wide the sweep is in terms of delay time, in percent. Varies from 0 (no effect) to 100 (maximal effect).
SweepRate | float | This parameter refers to the frequency of flanging. Varies from 0 to 100, in percent.
SweepPhase | float | Phase of delay, in degrees.

Remarks:

The Chorus differs from the Flanger in only a couple of ways. One difference is the amount of delay that is used. The delay times in a Chorus are larger than in a Flanger, usually somewhere between 20 ms. and 30 ms. (the Flanger's delay usually ranges from 1 ms. to 10 ms.) This longer delay doesn't produce the characteristic sweeping sound of the Flanger. The Chorus also differs from the Flanger in that there is generally no feedback used.

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

For more information about chorus effect see: http://www.harmony-central.com/Effects/Articles/Chorus/

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.Chorus LChannel(), 50, 40, 2, 40, 100
AudioTransform21.Chorus RChannel(), 50, 40, 2, 40, 100
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

AddNoise | Amplify | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | Invert | Normalize | Phaser | Resample | Reverb | Reverse | Silence | TrimLeft | TrimRight | Vibrato

Applies to: AudioTransform2

Send Feedback on the NCTAudioCompress documentation.
NCTAudioCompress was developed by NCT company http://www.nctsoft.com


Compressor method

Compressor method

Reduces the dynamic range of the signal.

Syntax

object.Compressor(WavArray As Integer(), dbThreshold As float, CompressionRate As float, RMSTime As float)

The Compressor method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array. The array size must be equal to or more than 2*RMSTime.
dbThreshold | float | Certain level for threshold, in db. Varies from -92 to 0.
CompressionRate | float | Rate of mixing signals, in percent. Varies from 1 (minimal effect) to 100 (maximal effect).
RMSTime | float | Time for root-mean-square calculation, in ms. Usually RMSTime is equal to 100 ms.

Remarks:

A compressor is basically a variable gain device, where the amount of gain used depends on the level of the input. In this case, the gain will be reduced when the signal level is high that makes louder passages softer, reducing the dynamic range. This effect equals to dynamic volume regulator.

This behavior is opposite to that of the Expander.

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

For more information about compression effect see: http://www.harmony-central.com/Effects/Articles/Compression/

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.Compressor LChannel(), -50, 4, 100
AudioTransform21.Compressor RChannel(), -50, 4, 100
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

AddNoise | Amplify | Chorus | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | Invert | Normalize | Phaser | Resample | Reverb | Reverse | Silence | TrimLeft | TrimRight | Vibrato

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


DBToPercent method

DBToPercent method

Converts value from db to percents.

Return Type

A float value.

Syntax

PercentValue = object.DBToPercent(dbValue As float)

The DBToPercent method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
dbValue | float | Value in db.
PercentValue | Float | Value in percents.

Remarks:

If dbValue < 0 then PercentValue > 100.

If dbValue > 0 then PercentValue < 100.

See Also:

PercentToDB

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


Delay method

Delay method

Applies delay effect to the existing audio data array.

Syntax

object.Delay(WavArray As Integer(), DelayTime As float, MixDepth As float, FeedBackGain As float)

The Delay method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.
DelayTime | float | Delay time, in milliseconds. Varies from 0 to 10000.
MixDepth | float | The dry is the volume of the input signal and the wet is the volume of the delayed signal, in percent. Varies from 0 to 100. If MixDepth = 0 the resulting signal does not contain delayed signal. If MixDepth = 100 the resulting signal does not contain input signal. Other values of MixDepth are a combination of the dry and the wet (wet = 100 - dry).
FeedBackGain | float | FeedBackGain sets how much delay is fed back to the input. Varies from 0 to 100.

Remarks:

Delay is an echo effect that replays what you have played ones or several times after a certain period of time. It's something like the echoes you might hear shouting against a wall.

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

For more information about delay effect see: http://www.harmony-central.com/Effects/Articles/Delay

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.Delay LChannel(), 120, 30, 50
AudioTransform21.Delay RChannel(), 120, 30, 50
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

AddNoise | Amplify | Chorus | Compressor | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | Invert | Normalize | Phaser | Resample | Reverb | Reverse | Silence | TrimLeft | TrimRight | Vibrato

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


DeleteSilence method

DeleteSilence method

Deletes silence from the existing audio data array.

Syntax

object.DeleteSilence(WavArray As Integer(), dbThreshold As float, AttackTime As Long, ReleaseTime As Long)

The DeleteSilence method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.
dbThreshold | float | Certain level for threshold, in db. Varies from -92 to 0.
AttackTime | Long | Time for volume increase, in ms. Usually the value of AttackTime property is much less than ReleaseTime. Varies from 0 to 1000.
ReleaseTime | Long | Time for volume decrease, in ms. Usually the value of AttackTime property is much less than ReleaseTime. Varies from 0 to 10000.

Remarks:

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

The following picture shows the change of volume for this method.

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
AudioTransform21.DeleteSilence Channel(), -25, 600, 3000, 100
AudioFile1.CloseFile

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | Envelope | Equalizer | Expander | Fade | Flanger | Invert | Normalize | Phaser | Resample | Reverb | Reverse | Silence | TrimLeft | TrimRight | Vibrato

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


DuplicateArray method

DuplicateArray method

Duplicates audio data array.

Syntax

object.DuplicateArray(WavArray As Integer())

The DuplicateArray method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.

See Also:

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


Envelope method

Envelope method

Gives you control over what parts of the audio data array are amplified or inverted (negative values), and by how much according to the data in EnvelopeArray. This method allows to set individual amplification factors for every individual sample in the audio data array.

Syntax

object.Envelope(WavArray As Integer(), EnvelopeArray As Float())

The Envelope method syntax has these parts:

Part | type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | The audio data array.
EnvelopeArray | float() | Envelope data array.

Remarks:

The number of elements in the envelope array has to be equal to the amount of samples in the audio data array. If the size of the envelope array is less than the amount of samples in the audio data array, the Envelope method has effect only on the first samples in the audio data array. Otherwise superfluous elements of the envelope array are not used.

You can assign any values to elements in the envelope array (amplification factors) according to the float data type. Here are several examples and its effects:

Sample values of the amplification factor | Effect
2 | Represents 100% (normal) amplification
1 | Has no effect
0.5 | Decreases the current sample value
0 | Represents full attenuation (silence)
-1 | Inverts the current sample value
-2 | Inverts and amplifies the current sample value to 100%

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
Dim EnvelopeArray() As Single
Dim i As Long
ReDim EnvelopeArray(1000)
For i = 0 To 999
    EnvelopeArray(i) = Sin(PI * i / 1000)
Next i
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.Envelope LChannel(), EnvelopeArray()
AudioTransform21.Envelope RChannel(), EnvelopeArray()
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Equalizer | Expander | Fade | Flanger | Invert | Normalize | Phaser | Resample | Reverb | Reverse | Silence | TrimLeft | TrimRight | Vibrato

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


Equalizer method

Equalizer method

Applies equalizing to the existing audio data array.

Syntax

object.Equalizer(WavArray As Integer(), dbGainArray As float(), FreqArray As float())

The Equalizer method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.
dbGainArray | float() | Gain array in db. All values vary from -92 to 92.
FreqArray | float() | Frequency array, in hertz.

Remarks:

Equalization (EQ) is the process of boosting or cutting certain frequency components in a signal.

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

For more information about equalizer effect see: http://www.harmony-central.com/Effects/Articles/Equalization/

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
Dim dbGain(11) As Single
Dim Freq(11) As Single
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
For i = 0 To 11: dbGain(i) = -sldEQ(i).Value: Next i
For i = 0 To 11: Freq(i) = sldEQ(i).Tag: Next i
AudioTransform21.Equalizer LChannel(), dbGain(), Freq()
AudioTransform21.Equalizer RChannel(), dbGain(), Freq()
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Fade | Flanger | Invert | Normalize | Phaser | Resample | Reverb | Reverse | Silence | TrimLeft | TrimRight | Vibrato

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


Expander method

Expander method

Adds expander effect to the audio data array. The expander is essentially an amplifier with a variable gain control.

Syntax

object.Expander(WavArray As Integer(), dbThreshold As float, ExpansionRate As float, RMSTime As float)

The Expander method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array. The array size must be equal to or more than 2*RMSTime.
dbThreshold | float | Certain value for threshold, in db. Varies from -92 to 0.
ExpansionRate | float | Rate of expansion. Varies from 1 (minimal effect) to 100 (maximal effect), in percent.
RMSTime | float | Time for root-mean-square calculation, in ms. Usually RMSTime is equal to 100 ms.

Remarks:

The expander is a type of dynamic processor. As the name implies, it increases the dynamic range of a signal so that low level signals are attenuated while the louder portions are neither attenuated nor amplified.

This behavior is opposite to that of the Compressor.

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

For more information about expansion effect see: http://www.harmony-central.com/Effects/Articles/Expansion/

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.Expander LChannel(), -50, 4, 100
AudioTransform21.Expander RChannel(), -50, 4, 100
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Fade | Flanger | Invert | Normalize | Phaser | Resample | Reverb | Reverse | Silence | TrimLeft | TrimRight | Vibrato

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


Fade method

Fade method

Creates a fading in (soft to loud) or fading out (loud to soft) effect in the existing audio data array. The audio data will be linearly faded from starting magnitude AmplifyLeft to ending magnitude AmplifyRight.

Syntax

object.Fade(WavArray As Integer(), AmpLeft As float, AmpRight As float)

The Fade method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.
AmpLeft | float | Starting value percent, from 0 to 100.
AmpRight | float | Ending value percent, from 0 to 100.

Remarks:

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.Fade LChannel(), 20, 40
AudioTransform21.Fade RChannel(), 20, 40
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Flanger | Invert | Normalize | Phaser | Resample | Reverb | Reverse | Silence | TrimLeft | TrimRight | Vibrato

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


FFTFilter method

FFTFilter method

Applies Fast Fourier filter to the existing audio data array.

Syntax

object.FFTFilter(WavArray As Integer(), FFTArray As float())

The FFTFilter method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.
FFTArray | float() | Percentage Fourier coefficients array. If all values of this array are equal to 1 audio data array does not change.

Remarks:

Dimension of FFTArray can be only 22n+1, for example 211 = 2048, 215 = 32768 and so on. It defines changing of audio data for fixed frequency bands.

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

The FFTArray can be visually create using AudioTransformDisplay2 object.

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
Dim FFTArray() As Single
Dim i As Integer
For i = 0 To 128 '27
    FFTArray(i) = 10 ^ ((i ^ 2) / 20)
Next i
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.FFTFilter LChannel(), FFTArray()
AudioTransform21.FFTFilter RChannel(), FFTArray()
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

BandPassFilter | HighPassFilter | HighShelfFilter | LowPassFilter | LowShelfFilter | NotchFilter | PeakEQFilter

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


FFTPhase method

FFTPhase method (AudioTransform2 object)

Applies the Fast Fourier transformation to the input audio array and returns an array of phase coefficients.

Return Type

A Float() value.

Syntax

FFTPhaseArray = object.FFTPhase(WavArray As Integer())

The FFTPhase method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | An input audio data array.
FFTPhaseArray | float() | A phase array of Fourier coefficients in db.

Remarks:

This method transforms the input WavArray array using the Fast Fourier transformation and after calculates and returns phase coefficients of this transformation.

The size of the input array dimension has to be equal to the 22n value, where n = 1,2,3,..,8. For example 256, 1024, 4096..., 65536. The size of the output array dimension will be equal to the 22n-1 value accordingly. It will contain 128, 512, 2048...., 32768 elements. If the input array contains more than 22n elements, for example 2000, only the first 1024 elements will be processed. The more array dimension is the higher is precision of calculating.

For example, if the input array contains 1024 elements of audio data of 44100 Hz sample rate, the output array will contain 512 elements which will represent phase coefficients for frequencies with 86 Hz step (44100 / 512 =86).

1 element of FFTPhaserArray - phase for 0 hertz
2 element of FFTPhaserArray - phase for 86 hertz
3 element of FFTPhaserArray - phase for 172 hertz
...
512 element of FFTPhaserArray - phase for 44014 hertz

See Also:

FFTPower

Applies to: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


FFTPower method

FFTPower method (AudioTransform2 object)

Applies the Fast Fourier transformation to the input audio array and returns an array of power coefficients.

Return Type

A Float() value.

Syntax

FFTPowerArray = object.FFTPower(WavArray As Integer())

The FFTPower method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | An input audio data array.
FFTPowerArray | float() | A power array of Fourier coefficients in db.

Remarks:

This method transforms the input WavArray array using the Fast Fourier transformation and after calculates and returns power coefficients of this transformation.

The size of the input array dimension has to be equal to the 22n value, where n = 1,2,3,..,8. For example 256, 1024, 4096..., 65536. The size of the output array dimension will be equal to the 22n-1 value accordingly. It will contain 128, 512, 2048...., 32768 elements. If the input array contains more than 22n elements, for example 2000, only the first 1024 elements will be processed. The more array dimension is the higher is precision of calculating.

For example, if the input array contains 1024 elements of audio data of 44100 Hz sample rate, the output array will contain 512 elements which will represent power coefficients for frequencies with 86 Hz step (44100 / 512 =86).

1 element of FFTPowerArray - power for the 0 hertz
2 element of FFTPowerArray - power for 86 hertz
3 element of FFTPowerArray - power for 172 hertz
...
512 element of FFTPowerArray - power for 44014 hertz

See Also:

FFTPhase

Applies to: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


Flanger method

Flanger method

Applies flanging effect to the existing audio data array.

Syntax

object.Flanger(WavArray As Integer(), DelayRate As float, MixDepth As float, FeedBackGain As float, SweepDepth As float, SweepRate As float, SweepPhase As float)

The Flanger method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.
DelayRate | float | Rate of delay. Varies from 0 (no delay) to 100 (20 ms delay).
MixDepth | float | The dry is the volume of the input signal and the wet is the volume of the delayed signal, in percent. Varies from 0 to 100. If MixDepth = 0 the resulting signal does not contain delayed signal. If MixDepth = 100 the resulting signal does not contain input signal. Other values of MixDepth are a combination of the dry and the wet (wet = 100 - dry).
FeedBackGain | float | FeedBackGain sets how much delay is fed back to the input. Varies from 0 to 100.
SweepDepth | float | The sweep depth determines how wide the sweep is in terms of delay time, in percent. Varies from 0 (no effect) to 100 (maximal effect).
SweepRate | float | This parameter refers to the frequency of flanging. Varies from 0 to 100, in percent.
SweepPhase | float | Phase of delay, in radian.

Remarks:

Flanging is created by mixing a signal with a slightly delayed copy of itself, where the length of the delay is constantly changing. It is actually one specific type of phasing (Phaser).

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

For more information about flanging effect see: http://www.harmony-central.com/Effects/Articles/Flanging

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.Flanger LChannel(), 50, 30, 10, 50, 5
AudioTransform21.Flanger RChannel(), 50, 30, 10, 50, 5
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Invert | Normalize | Phaser | Resample | Reverb | Reverse | Silence | TrimLeft | TrimRight | Vibrato

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


GetLeftStereoChannel method

GetLeftStereoChannel method

Gets audio data array of the left stereo channel from the existing audio data array.

Return Type

A Integer() value.

Syntax

object.GetLeftStereoChannel(StereoArray As Integer())

The GetLeftStereoChannel method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
StereoArray | Integer() | Audio data array.

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
Dim EnvelopeArray() As Single
Dim i As Long
ReDim EnvelopeArray(1000)
For i = 0 To 999
    EnvelopeArray(i) = Sin(PI * i / 1000)
Next i
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.Envelope LChannel(), EnvelopeArray()
AudioTransform21.Envelope RChannel(), EnvelopeArray()
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

GetRightStereoChannel

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


GetRightStereoChannel method

GetRightStereoChannel method

Gets audio data array of the right stereo channel from the existing audio data array.

Return Type

A Integer() value.

Syntax

object.GetRightStereoChannel(StereoArray As Integer())

The GetRightStereoChannel method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
StereoArray | Integer() | Audio data array.

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
Dim EnvelopeArray() As Single
Dim i As Long
ReDim EnvelopeArray(1000)
For i = 0 To 999
    EnvelopeArray(i) = Sin(PI * i / 1000)
Next i
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.Envelope LChannel(), EnvelopeArray()
AudioTransform21.Envelope RChannel(), EnvelopeArray()
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

GetLeftStereoChannel

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


HighPassFilter method

HighPassFilter method

Applies High Pass filter to the existing audio data array.

Syntax

object.HighPassFilter(WavArray As Integer(), Frequency As float, Steepness As float)

The HighPassFilter method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.
Frequency | float | Central frequency of the filter, in hertz.
Steepness | float | Steepness of the filter. Can be from 0.01 to 100.

Remarks:

High Pass filter cuts the lowest frequencies and passes the highest.

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

For more information about High Pass filter effect see: FiltersInformation

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.HighPassFilter LChannel(), 800, 50
AudioTransform21.HighPassFilter RChannel(), 800, 50
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

BandPassFilter | FFTFilter | HighShelfFilter | LowPassFilter | LowShelfFilter | NotchFilter | PeakEQFilter

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


HighShelfFilter method

HighShelfFilter method

Applies High Shelf filter (treble control) to the existing audio data array.

Return Type

A Boolean value.

Syntax

object.HighShelfFilter(WavArray As Integer(), dbGain As float, Frequency As float, Steepness As float)

The HighShelfFilter method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.
dbGain | float | Gain in db, from 0.01 to 92.
Frequency | float | Central frequency of the filter, in hertz.
Steepness | float | Steepness of the filter, from 0.01 to 100.

Remarks:

High Shelf filter decreases the volume of the lowest frequencies and passes the highest.

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

For more information about High Shelf filter effect see: FiltersInformation

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.HighShelfFilter LChannel(), 40, 800, 50
AudioTransform21.HighShelfFilter RChannel(), 40, 800, 50
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

BandPassFilter | FFTFilter | HighPassFilter | LowPassFilter | LowShelfFilter | NotchFilter | PeakEQFilter

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


Invert method

Invert method

Inverts the existing audio data array.

Syntax

object.Invert(WavArray As Integer())

The Invert method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.

Remarks:

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.Invert LChannel()
AudioTransform21.Invert RChannel()
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | Normalize | Phaser | Resample | Reverb | Reverse | Silence | TrimLeft | TrimRight | Vibrato

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


LowPassFilter method

LowPassFilter method

Applies Low Pass filter to the existing audio data array.

Syntax

object.LowPassFilter(WavArray As Integer(), Frequency As float, Steepness As float)

The LowPassFilter method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.
Frequency | float | Central frequency of the filter, in hertz.
Steepness | float | Steepness of the filter, from 0.01 to 100.

Remarks:

The Low Pass filter allows only the lower frequencies to be present into the output signal; it will cut the beautiful crystal sound of a violin (frequencies over 10 KHz), but if it could amplify rather than just pass the low frequencies, than it would enhance your favorite disco music with lots of percussions and bass.

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

For more information about Low Pass filter effect see: FiltersInformation

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.LowPassFilter LChannel(), 800, 50
AudioTransform21.LowPassFilter RChannel(), 800, 50
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

BandPassFilter | FFTFilter | HighPassFilter | HighShelfFilter | LowShelfFilter | NotchFilter | PeakEQFilter

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


LowShelfFilter method

LowShelfFilter method

Applies Low Shelf filter (bass control) to the existing audio data array.

Syntax

object.LowShelfFilter(WavArray As Integer(), dbGain As float, Frequency As float, Steepness As float)

The LowShelfFilter method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.
dbGain | float | Gain in db, from 0.01 to 92.
Frequency | float | Central frequency of the filter, in hertz.
Steepness | float | Steepness of the filter, from 0.01 to 100.

Remarks:

Low Shelf filter decreases the volume of the highest frequencies and passes the lowest.

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

For more information about Low Shelf filter effect see: FiltersInformation

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.LowShelfFilter LChannel(), 40, 800, 50
AudioTransform21.LowShelfFilter RChannel(), 40, 800, 50
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

BandPassFilter | FFTFilter | HighPassFilter | HighShelfFilter | LowPassFilter | NotchFilter | PeakEQFilter

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


MakeMonoFromStereo method

MakeMonoFromStereo method

Makes mono audio data array from stereo audio data array.

Return Type

A Integer() value.

Syntax

MonoArray = object.MakeMonoFromStereo(StereoArray As Integer())

The MakeMonoFromStereo method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
StereoArray | Integer() | Stereo audio data array.
MonoArray | Integer() | Mono audio data array.

Remarks:

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

See Also:

MakeStereoFromArrays | MakeStereoFromMono

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


MakeStereoFromArrays method

MakeStereoFromArrays method

Makes stereo audio data array from separate left and right channels audio data arrays.

Return Type

A Integer() value.

Syntax

StereoArray = object.MakeStereoFromArrays(LeftArray As Integer(), RightArray As Integer())

The MakeStereoFromArrays method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
LeftArray | Integer() | Left mono audio data array.
RightArray | Integer() | Right mono audio data array.
StereoArray | Integer() | Stereo audio data array.

Remarks:

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
Dim EnvelopeArray() As Single
Dim i As Long
ReDim EnvelopeArray(1000)
For i = 0 To 999
    EnvelopeArray(i) = Sin(PI * i / 1000)
Next i
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.Envelope LChannel(), EnvelopeArray()
AudioTransform21.Envelope RChannel(), EnvelopeArray()
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

MakeMonoFromStereo | MakeStereoFromMono

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


MakeStereoFromMono method

MakeStereoFromMono method

Makes stereo audio data array from mono audio data array.

Return Type

A Integer() value.

Syntax

StereoArray = object.MakeStereoFromMono(MonoArray As Integer())

The MakeStereoFromMono method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object of type .
MonoArray | Integer() | Mono audio data array.
StereoArray | Integer() | Stereo audio data array.

Remarks:

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
Dim EnvelopeArray() As Single
Dim i As Long
ReDim EnvelopeArray(1000)
For i = 0 To 999
    EnvelopeArray(i) = Sin(PI * i / 1000)
Next i
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.Envelope LChannel(), EnvelopeArray()
AudioTransform21.Envelope RChannel(), EnvelopeArray()
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

MakeMonoFromStereo | MakeStereoFromArrays

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


MixArrays method

MixArrays method

Creates output audio data array by mixing two input audio data arrays.

Return Type

A Integer() value.

Syntax

MixArray = object.MixArrays(InpArray1 As Integer(), Ampl1 As float, InpArray2 As Integer(), Amp2 As float)

The MixArrays method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
InpArray1 | Integer() | First input audio data array.
Ampl1 | float | Amplification percent for the first array. Values of this array vary from 0 to 100.
InpArray2 | Integer() | Second input audio data array.
Amp2 | float | Amplification percent for the second array. Values of this array vary from 0 to 100.
MixArray | Integer() | Audio data array.

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
Dim NChannel() As Integer
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
NChannel() = AudioTransform21.DuplicateArray(LChannel())
AudioTransform21.Reverse NChannel()
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
LChannel() = AudioTransform21.MixArrays(LChannel(), 30, NChannel(), 40)
NChannel() = AudioTransform21.DuplicateArray(RChannel())
AudioTransform21.Reverse NChannel()
RChannel() = AudioTransform21.MixArrays(RChannel(), 30, NChannel(), 40)
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

MixStereoChannels

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


MixStereoChannels method

NCTAudioCompress ActiveX DLL
MixStereoChannels method (AudioTransform2 object)

Mixes stereo channels in audio data array.

Syntax

object.MixStereoChannels(WavArray As Integer(), LLAmp As float, LRAmp As float, RLAmp As float, RRAmp As float)

The MixStereoChannels method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.
LLAmp | float | A percentage left channels time. Varies from 0 to 100.
LRAmp | float | A percentage left and right channels time. Varies from 0 to 100.
RLAmp | float | A percentage right and left channels time. Varies from 0 to 100.
RRAmp | float | A percentage right channels time. Varies from 0 to 100.

Remarks:

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

Example:

' VB sample where AudioTransform1 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform1.MakeStereoFromMono(Channel())
End If
AudioTransform1.MixStereoChannels Channel(), 30, 40, 30, 40
AudioFile1.CloseFile

See Also:

MixArrays

Applies to: AudioTransform2

Send Feedback on the NCTAudioCompress documentation.
NCTAudioCompress was developed by NCT company http://www.nctsoft.com


Normalize method

Normalize method

Normalizes the existing audio data array.

Syntax

object.Normalize(WavArray As Integer(), Normalization As float, DCBiasAdjust As Boolean)

The Normalize method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.
Normalization | float | Normalization percent. Can accept values from 0 to 100. The percentage of maximum to which you want to normalize. For example, choose 50% to compute values needed to amplify the selection no more than 50% of maximum.
DCBiasAdjust | Boolean | Can be True (leveling) or False (not leveling).

Remarks:

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

Amplifies the selection part to within the specified percentage of the maximum level.

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.Normalize LChannel(), 80, True
AudioTransform21.Normalize RChannel(), 80, True
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | Invert | Phaser | Resample | Reverb | Reverse | Silence | TrimLeft | TrimRight | Vibrato

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


NotchFilter method

NotchFilter method

Applies Notch filter to the existing audio data array.

Syntax

object.NotchFilter(WavArray As Integer(), Frequency As float, Steepness As float)

The NotchFilter method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.
Frequency | float | Central frequency of the filter, in hertz.
Steepness | float | Steepness of the filter, from 0.01 to 100.

Remarks:

Cuts input frequency from audio data array.

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

For more information about Notch filter effect see: FiltersInformation

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.NotchFilter LChannel(), 800, 50
AudioTransform21.NotchFilter RChannel(), 800, 50
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

BandPassFilter | FFTFilter | HighPassFilter | HighShelfFilter | LowPassFilter | LowShelfFilter | PeakEQFilter

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


PeakEQFilter method

PeakEQFilter method

Applies Peak EQ filter to the existing audio data array.

Syntax

object.PeakEQFilter(WavArray As Integer(), dbGain As float, Frequency As float, Steepness As float)

The PeakEQFilter method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.
dbGain | float | Gain in db, from 0.01 to 92.
Frequency | float | Central frequency of the filter, in hertz.
Steepness | float | Steepness of the filter, from 0.01 to 100.

Remarks:

The Peak EQ filter decreases the volume of the peaks.

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

For more information about Peak EQ filter effect see: FiltersInformation

See Also:

BandPassFilter | FFTFilter | HighPassFilter | HighShelfFilter | LowPassFilter | LowShelfFilter | NotchFilter

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


PercentToDB method

PercentToDB method

Converts value from percents to db.

Return Type

A float value.

Syntax

dbValue = object.PercentToDB(PercentValue As float)

The PercentToDB method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
PercentValue | float | Value in percents.
dbValue | float | Value in db.

Remarks:

If PercentValue < 0 then dbValue > 100.

If PercentValue > 0 then dbValue < 100.

See Also:

DBToPercent

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


Phaser method

Phaser method

Applies phasing effect to the existing audio data array.

Syntax

object.Phaser(WavArray As Integer(), DelayTime As float, MixDepth As float, FeedBackGain As float)

The Phaser method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.
DelayTime | float | Delay time, in milliseconds. Varies from 0 to 10000.
MixDepth | float | The dry is the volume of the input signal and the wet is the volume of the delayed signal, in percent. Varies from 0 to 100. If MixDepth = 0 the resulting signal does not contain delayed signal. If MixDepth = 100 the resulting signal does not contain input signal. Other values of MixDepth are a combination of the dry and the wet (wet = 100 - dry).
FeedBackGain | float | FeedBackGain sets how much delay is fed back to the input. Varies from 0 to 100.

Remarks:

The phaser achieves its distinctive sound by creating one or more notches in the frequency domain that eliminate sounds at the notch frequencies.

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

For more information about expansion effect see: http://www.harmony-central.com/Effects/Articles/Phase_Shifting/

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.Phaser LChannel(), 120, 30, 50
AudioTransform21.Phaser RChannel(), 120, 30, 50
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | Invert | Normalize | Resample | Reverb | Reverse | Silence | TrimLeft | TrimRight | Vibrato

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


PitchShift method

NCTAudioCompress ActiveX DLL
PitchShift method (AudioTransform2 object)

Changes the frequency of the audio file.

Syntax

object.PitchShift(WavArray As Integer(), Rate As float)

The PitchShift method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.
Rate | float | Degree of frequency change.

Remarks:

For example, for the files with voice this method increases or decreases timbre of voice.

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.PitchShift LChannel(), 150
AudioTransform21.PitchShift RChannel(), 150
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

TimeStretch

Applies to: AudioTransform2

Send Feedback on the NCTAudioCompress documentation.
NCTAudioCompress was developed by NCT company http://www.nctsoft.com


Register method

Register method

Enters user name and registration password to disable About window.

Syntax

object.Register(bstrUser As String, bstrPassword As String)

The Register method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object of type .
bstrUser | String | User name. You get a registration user name after the registration.
bstrPassword | String | Password string. You get a registration password after the registration.

Example:

' VB sample where Transform1 is an AudioTransform2 object.
Transform1.Register "XXX", "XXX"

See Also:

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


Resample method

Resample method

Decreases or increases the rate of the existing audio data array.

Syntax

object.Resample(WavArray As Integer(), Rate As float)

The Resample method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.
Rate | float | The percent of increase/decrease. Varies from 50 to 150. If Rate = 100 rate is not changed. If Rate < 100 rate is decreased, otherwise rate is increased.

Remarks:

Fastens of reduces the existing rate of the melody.

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.Resample LChannel(), 125
AudioTransform21.Resample RChannel(), 125
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | Invert | Normalize | Phaser | Reverb | Reverse | Silence | TrimLeft | TrimRight | Vibrato

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


Reverb method

Reverb method

Reverberates the existing audio data array.

Syntax

object.Reverb(WavArray As unknown - type, DelayTime As float, MixDepth As float, FeedBackGain As float, ReverberationGain As float, ReverberationFrequency As float, nTapDelay As Long)

The Reverb method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.
DelayTime | float | The delay time, in ms. Varies from 0 to 10000.
MixDepth | float | The dry is the volume of the input signal and the wet is the volume of the delayed signal, in percent. Varies from 0 to 100. If MixDepth = 0 the resulting signal does not contain delayed signal. If MixDepth = 100 the resulting signal does not contain input signal. Other values of MixDepth are a combination of the dry and the wet (wet = 100 - dry).
FeedBackGain | float | The feedback sets how much delay is fed back to the input. Varies from 0 to 100.
ReverberationGain | float | The level of reverberation signal in db.
ReverberationFrequency | float | The certain frequency of the reverberation effect, in hertz.
nTapDelay | Long | The number of taps before delay is fed back to the input.

Remarks:

It is the sound you hear in a room with hard surfaces where sound bounces around the room for a while after the initial sound stops.

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

For more information about flanging effect see: http://www.harmony-central.com/Effects/Articles/Reverb/.

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.Reverb LChannel(), 400, 30, 10, 50
AudioTransform21.Reverb RChannel(), 400, 30, 10, 50
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | Invert | Normalize | Phaser | Resample | Reverse | Silence | TrimLeft | TrimRight | Vibrato

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


Reverse method

Reverse method

Reverses the existing audio data array.

Syntax

object.Reverse(WavArray As Integer())

The Reverse method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.

Remarks:

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.Reverse LChannel()
AudioTransform21.Reverse RChannel()
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | Invert | Normalize | Phaser | Resample | Reverb | Silence | TrimLeft | TrimRight | Vibrato

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


Silence method

Silence method

Inserts silence in the existing audio data array.

Syntax

object.Silence(WavArray As Integer())

The Silence method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.

Remarks:

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.Silence LChannel()
AudioTransform21.Silence RChannel()
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | Invert | Normalize | Phaser | Resample | Reverb | Reverse | TrimLeft | TrimRight | Vibrato

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


TimeStretch method

NCTAudioCompress ActiveX DLL
TimeStretch method (AudioTransform2 object)

Stretches an audio array by time.

Syntax

object.TimeStretch(WavArray As Integer(), Rate As float)

The TimeStretch method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.
Rate | float | The rate of the stretching.

Remarks:

For example for the voice audio file the speech is increased or decreased without frequency changing.

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.TimeStretch LChannel(), 150
AudioTransform21.TimeStretch RChannel(), 150
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

PitchShift

Applies to: AudioTransform2

Send Feedback on the NCTAudioCompress documentation.
NCTAudioCompress was developed by NCT company http://www.nctsoft.com


TrimLeft method

TrimLeft method

Trims the existing audio data array from the beginning, deleting silence.

Syntax

object.TrimLeft(WavArray As Integer(), dbTrimLevel As float, FadeTime As float)

The TrimLeft method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.
dbTrimLevel | float | Maximal amplitude in db, which is considered as silence.
FadeTime | float | Time of trim fade, in ms.

Remarks:

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
    Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
AudioTransform21.TrimLeft Channel(), -40, 300
AudioTransform21.TrimRight Channel(), -40, 300
AudioFile1.CloseFile

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | Invert | Normalize | Phaser | Resample | Reverb | Reverse | Silence | TrimRight | Vibrato

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


TrimRight method

TrimRight method

Trims the existing audio data array from the finish, deleting silence.

Syntax

object.TrimRight(WavArray As Integer(), dbTrimLevel As float, FadeTime As float)

The TrimRight method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.
dbTrimLevel | float | Maximal amplitude in db, which is considered as silence.
FadeTime | float | Time of trim fade, in ms.

Remarks:

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
    Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
AudioTransform21.TrimLeft Channel(), -40, 300
AudioTransform21.TrimRight Channel(), -40, 300
AudioFile1.CloseFile

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | Invert | Normalize | Phaser | Resample | Reverb | Reverse | Silence | TrimLeft | Vibrato

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


Vibrato method

Vibrato method

Applies Vibrato effect to the existing audio data array.

Syntax

object.Vibrato(WavArray As Integer(), SweepDepth As float, SweepFrequency As float, SweepPhase As float)

The Vibrato method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.
SweepDepth | float | The depth of the vibrato effect, in percent. Varies from 0 (no effect) to 100 (maximal effect).
SweepFrequency | float | The certain frequency of the vibrato effect, in hertz.
SweepPhase | float | Phase of delay, in radian.

Remarks:

Vibrato equals to a cyclical changing of a certain frequency of the input signal.

Before applying this method ArrayChannels and ArrayFrequency properties must be set.

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.Vibrato LChannel(), 50, 4, 0
AudioTransform21.Vibrato RChannel(), 50, 4, 180
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | Invert | Normalize | Phaser | Resample | Reverb | Reverse | Silence | TrimLeft | TrimRight

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


AudioTransform2 events

AudioTransform2 events

Event | Description
EndTransform | Occurs when transformation process is completed.
TransformBlock | Occurs when some operation with audio data array is executed.


EndTransform event

EndTransform event

Occurs when transformation process is completed.

Syntax

Sub object_EndTransform()

See Also:

TransformBlock

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


TransformBlock event

TransformBlock event

Occurs when some operation with audio data array is executed.

Syntax

Sub object_TransformBlock(Percent As Long)

The TransformBlock event syntax has these named arguments:

Part | Type | Description
Percent | Long | Execution percent.

See Also:

EndTransform

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


KeyCode property (AudioTransform2 object)

Cookbook formulae for audio EQ biquad filter coefficients

All filter transfer functions were derived from analog prototypes (that
are shown below for each EQ filter type) and digitized using the
Bilinear Transform. BLT frequency warping has been taken into account
for both significant frequency relocation and for bandwidth readjustment.

First, given a biquad transfer function defined as:

b0 + b1*z^-1 + b2*z^-2
H(z) =
a0 + a1*z^-1 + a2*z^-2

This shows 6 coefficients instead of 5 so, depending on your architecture,
you will likely normalize a0 to be 1 and perhaps also b0 to 1 (and collect
that into an overall gain coefficient). Then your transfer function would
look like:

(b0/a0) + (b1/a0)*z^-1 + (b2/a0)*z^-2
H(z) =
1 + (a1/a0)*z^-1 + (a2/a0)*z^-2

or

1 + (b1/b0)*z^-1 + (b2/b0)*z^-2
H(z) = (b0/a0) *
1 + (a1/a0)*z^-1 + (a2/a0)*z^-2

The most straight forward implementation would be the Direct I form (second equation):

y[n] = (b0/a0)*x[n] + (b1/a0)*x[n-1] + (b2/a0)*x[n-2] - (a1/a0)*y[n-1] - (a2/a0)*y[n-2]

This is probably both the best and the easiest method to implement in the 56K.

Now, given:

sampleRate (the sampling frequency)

frequency ("wherever it's happenin', man." "center" frequency
or "corner" (-3 dB) frequency, or shelf midpoint frequency,
depending on which filter type)

dBgain (used only for peaking and shelving filters)

bandwidth in octaves (between -3 dB frequencies for BPF and notch
or between midpoint (dBgain/2) gain frequencies for peaking EQ)

_or_ Q (the Electrical Engineering kind of definition)

_or_ S, a "shelf slope" parameter (for shelving EQ only). when S = 1,
the shelf slope is as steep as it can be and remain monotonically
increasing or decreasing gain with frequency.

First compute a few intermediate variables:

A = sqrt[ 10^(dBgain/20) ]
= 10^(dBgain/40) (for peaking and shelving EQ filters only)

omega = 2*PI*frequency/sampleRate

sin = sin(omega)
cos = cos(omega)

alpha = sin/(2*Q) (if Q is specified)
= sin*sinh[ ln(2)/2 * bandwidth * omega/sin ] (if bandwidth is specified)

beta = sqrt[ (A^2 + 1)/S - (A-1)^2 ] (for shelving EQ filters only)

Then compute the coefs for whichever filter type you want:

The analog prototypes are shown for normalized frequency.
The bilinear transform substitutes:

1 1 - z^-1
s <- *
tan(omega/2) 1 + z^-1

LPF: H(s) = 1 / (s2 + s/Q + 1)

b0 = (1 - cos)/2
b1 = 1 - cos
b2 = (1 - cos)/2
a0 = 1 + alpha
a1 = -2*cos
a2 = 1 - alpha

HPF: H(s) = s2 / (s2 + s/Q + 1)

b0 = (1 + cos)/2
b1 = -(1 + cos)
b2 = (1 + cos)/2
a0 = 1 + alpha
a1 = -2*cos
a2 = 1 - alpha

BPF (constant skirt gain): H(s) = s / (s2 + s/Q + 1)

b0 = Q*alpha
b1 = 0
b2 = -Q*alpha
a0 = 1 + alpha
a1 = -2*cos
a2 = 1 - alpha

BPF (constant peak gain): H(s) = (s/Q) / (s2 + s/Q + 1)

b0 = alpha
b1 = 0
b2 = -alpha
a0 = 1 + alpha
a1 = -2*cos
a2 = 1 - alpha

Notch: H(s) = (s2 + 1) / (s2 + s/Q + 1)

b0 = 1
b1 = -2*cos
b2 = 1
a0 = 1 + alpha
a1 = -2*cos
a2 = 1 - alpha

PeakingEQ: H(s) = (s2 + s*(A/Q) + 1) / (s2 + s/(A*Q) + 1)

b0 = 1 + alpha*A
b1 = -2*cos
b2 = 1 - alpha*A
a0 = 1 + alpha/A
a1 = -2*cos
a2 = 1 - alpha/A

LowShelf: H(s) = A * (s2 + beta*s + A) / (A*s2 + beta*s + 1)

b0 = A*[ (A+1) - (A-1)*cos + beta*sin ]
b1 = 2*A*[ (A-1) - (A+1)*cos ]
b2 = A*[ (A+1) - (A-1)*cos - beta*sin ]
a0 = (A+1) + (A-1)*cos + beta*sin
a1 = -2*[ (A-1) + (A+1)*cos ]
a2 = (A+1) + (A-1)*cos - beta*sin

HighShelf: H(s) = A * (A*s2 + beta*s + 1) / (s2 + beta*s + A)

b0 = A*[ (A+1) + (A-1)*cos + beta*sin ]
b1 = -2*A*[ (A-1) + (A+1)*cos ]
b2 = A*[ (A+1) + (A-1)*cos - beta*sin ]
a0 = (A+1) - (A-1)*cos + beta*sin
a1 = 2*[ (A-1) - (A+1)*cos ]
a2 = (A+1) - (A-1)*cos - beta*sin


AudioTransformDisplay2

AudioTransformDisplay2 object

AudioTransformDisplay2 object is intended for visual representation of creating the FFTArray array for FFTFilter method.

This object contains the following methods and properties for:

  • creating and getting FFTArray array (GetLineArray, LineArraySize, SplineStepness, SplineType);

  • visualized representation:

  • tick (GetPointArray, SetPoint, SetPointArray, PointColor);

  • scale view (ScaleColor, ScaleFont, ScaleXCaption, ScaleXMax, ScaleXMin, ScaleXVisible, ScaleYCaption, ScaleYMax, ScaleYMin, ScaleYVisible, LogScale, MouseXToScaleX, MouseYToScaleY);

  • grid view (GridColor, GridVisible);

  • border view (BorderColor, BorderStyle);

  • general window view (BackColor, Color, TextColor).

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


AudioTransformDisplay2 properties

AudioTransformDisplay2 properties

Property | Type | Default | Description
BackColor | OLE_COLOR |  | Gets or sets RGB color of background using standard Windows palette.
BorderColor | OLE_COLOR |  | Gets or sets RGB color of the border using standard Windows palette.
BorderStyle | BorderTypeConstants |  | Gets or sets the type of the border.
Color | OLE_COLOR |  | Gets or sets RGB color of the line using standard Windows palette.
GridColor | OLE_COLOR |  | Gets or sets RGB color of the grid using standard Windows palette.
GridVisible | Boolean |  | Gets or sets a flag of grid visibility.
LineArraySize | Long |  | Gets or sets the size of the array get by GetLineArray method.
LogScale | Boolean |  | Gets or sets a flag indicating if horizontal scale is logarithmic or not.
PointColor | OLE_COLOR |  | Gets or sets RGB color of ticks using standard Windows palette.
ScaleColor | OLE_COLOR |  | Gets or sets RGB color of the scale using standard Windows palette.
ScaleFont | IFontDisp |  | Gets or sets the font of the scale using standard Windows fonts.
ScaleXCaption | String |  | Gets or sets the caption of the horizontal scale.
ScaleXMax | float |  | Gets or sets the maximum value of the horizontal scale.
ScaleXMin | float |  | Gets or sets the minimum value of the horizontal scale.
ScaleXVisible | Boolean |  | Gets or sets a flag of the horizontal scale visibility.
ScaleYCaption | String |  | Gets or sets the caption of the vertical scale.
ScaleYMax | float |  | Gets or sets the maximum value of the vertical scale.
ScaleYMin | float |  | Gets or sets the minimum value of the vertical scale.
ScaleYVisible | Boolean |  | Gets or sets a flag of the vertical scale visibility.
SplineSteepnes | Long |  | Gets or sets the steepness of the spline.
SplineType | SplineTypeConstants |  | Gets or sets the type of the spline.
TextColor | OLE_COLOR |  | Gets or sets RGB color of the text using standard Windows palette.


BackColor property (AudioTransformDisplay2 object)

BackColor property (AudioTransformDisplay2 object)

Gets or sets RGB color of background using standard Windows palette.

Property type

A OLE_COLOR value.

Syntax

object.BackColor [= value]

The BackColor property syntax has these parts:

Part | Type | Description
object | AudioTransformDisplay2 | An expression evaluating to an object.
value | OLE_COLOR | Color type. By default this property is set to window background color.

Example:

' VB sample where Display is an AudioTransformDisplay2 object and AudioFile1 is an AudioFile2 object.
Display.BackColor = System.Drawing.Color.Gray
Display.BorderColor = System.Drawing.Color.Gray
Display.BorderStyle = bSingle
Display.Color = System.Drawing.Color.Black
Display.GridColor = System.Drawing.Color.White
Display.GridVisible = True
Display.LogScale = False
Display.ScaleColor = System.Drawing.Color.Green
Display.ScaleFont = New System.Drawing.Font("Times", 36, FontStyle.Bold)
Display.ScaleXCaption = "Hz"
Display.ScaleXMax = 20000
Display.ScaleXMin = 20
Display.ScaleXVisible = True
Display.ScaleYCaption = "dB"
Display.ScaleYMax = 15
Display.ScaleYMin = -15
Display.ScaleYVisible = True
Display.TextColor = System.Drawing.Color.Blue
Display.PointColor = System.Drawing.Color.Pink

See Also:

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


BorderColor property (AudioTransformDisplay2 object)

BorderColor property (AudioTransformDisplay2 object)

Gets or sets RGB color of the border using standard Windows palette.

Property type

A OLE_COLOR value.

Syntax

object.BorderColor [= value]

The BorderColor property syntax has these parts:

Part | Type | Description
object | AudioTransformDisplay2 | An expression evaluating to an object.
value | OLE_COLOR | Color type.

Example:

' VB sample where Display is an AudioTransformDisplay2 object and AudioFile1 is an AudioFile2 object.
Display.BackColor = System.Drawing.Color.Gray
Display.BorderColor = System.Drawing.Color.Gray
Display.BorderStyle = bSingle
Display.Color = System.Drawing.Color.Black
Display.GridColor = System.Drawing.Color.White
Display.GridVisible = True
Display.LogScale = False
Display.ScaleColor = System.Drawing.Color.Green
Display.ScaleFont = New System.Drawing.Font("Times", 36, FontStyle.Bold)
Display.ScaleXCaption = "Hz"
Display.ScaleXMax = 20000
Display.ScaleXMin = 20
Display.ScaleXVisible = True
Display.ScaleYCaption = "dB"
Display.ScaleYMax = 15
Display.ScaleYMin = -15
Display.ScaleYVisible = True
Display.TextColor = System.Drawing.Color.Blue
Display.PointColor = System.Drawing.Color.Pink

See Also:

BorderStyle

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


BorderStyle property (AudioTransformDisplay2 object)

BorderStyle property (AudioTransformDisplay2 object)

Gets or sets the type of the border.

Property type

A BorderTypeConstants value.

Syntax

object.BorderStyle [= value]

The BorderStyle property syntax has these parts:

Part | Type | Description
object | AudioTransformDisplay2 | An expression evaluating to an object.
value | BorderTypeConstants | The type of border style.

Example:

' VB sample where Display is an AudioTransformDisplay2 object and AudioFile1 is an AudioFile2 object.
Display.BackColor = System.Drawing.Color.Gray
Display.BorderColor = System.Drawing.Color.Gray
Display.BorderStyle = bSingle
Display.Color = System.Drawing.Color.Black
Display.GridColor = System.Drawing.Color.White
Display.GridVisible = True
Display.LogScale = False
Display.ScaleColor = System.Drawing.Color.Green
Display.ScaleFont = New System.Drawing.Font("Times", 36, FontStyle.Bold)
Display.ScaleXCaption = "Hz"
Display.ScaleXMax = 20000
Display.ScaleXMin = 20
Display.ScaleXVisible = True
Display.ScaleYCaption = "dB"
Display.ScaleYMax = 15
Display.ScaleYMin = -15
Display.ScaleYVisible = True
Display.TextColor = System.Drawing.Color.Blue
Display.PointColor = System.Drawing.Color.Pink

See Also:

BorderColor

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


Color property (AudioTransformDisplay2 object)

Color property (AudioTransformDisplay2 object)

Gets or sets RGB color of the line using standard Windows palette.

Property type

A OLE_COLOR value.

Syntax

object.Color [= value]

The Color property syntax has these parts:

Part | Type | Description
object | AudioTransformDisplay2 | An expression evaluating to an object.
value | OLE_COLOR | The color type.

Example:

' VB sample where Display is an AudioTransformDisplay2 object and AudioFile1 is an AudioFile2 object.
Display.BackColor = System.Drawing.Color.Gray
Display.BorderColor = System.Drawing.Color.Gray
Display.BorderStyle = bSingle
Display.Color = System.Drawing.Color.Black
Display.GridColor = System.Drawing.Color.White
Display.GridVisible = True
Display.LogScale = False
Display.ScaleColor = System.Drawing.Color.Green
Display.ScaleFont = New System.Drawing.Font("Times", 36, FontStyle.Bold)
Display.ScaleXCaption = "Hz"
Display.ScaleXMax = 20000
Display.ScaleXMin = 20
Display.ScaleXVisible = True
Display.ScaleYCaption = "dB"
Display.ScaleYMax = 15
Display.ScaleYMin = -15
Display.ScaleYVisible = True
Display.TextColor = System.Drawing.Color.Blue
Display.PointColor = System.Drawing.Color.Pink

See Also:

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


GridColor property (AudioTransformDisplay2 object)

GridColor property (AudioTransformDisplay2 object)

Gets or sets RGB color of the grid using standard Windows palette.

Property type

A OLE_COLOR value.

Syntax

object.GridColor [= value]

The GridColor property syntax has these parts:

Part | Type | Description
object | AudioTransformDisplay2 | An expression evaluating to an object.
value | OLE_COLOR | Color type.

Example:

' VB sample where Display is an AudioTransformDisplay2 object and AudioFile1 is an AudioFile2 object.
Display.BackColor = System.Drawing.Color.Gray
Display.BorderColor = System.Drawing.Color.Gray
Display.BorderStyle = bSingle
Display.Color = System.Drawing.Color.Black
Display.GridColor = System.Drawing.Color.White
Display.GridVisible = True
Display.LogScale = False
Display.ScaleColor = System.Drawing.Color.Green
Display.ScaleFont = New System.Drawing.Font("Times", 36, FontStyle.Bold)
Display.ScaleXCaption = "Hz"
Display.ScaleXMax = 20000
Display.ScaleXMin = 20
Display.ScaleXVisible = True
Display.ScaleYCaption = "dB"
Display.ScaleYMax = 15
Display.ScaleYMin = -15
Display.ScaleYVisible = True
Display.TextColor = System.Drawing.Color.Blue
Display.PointColor = System.Drawing.Color.Pink

See Also:

GridVisible

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


GridVisible property (AudioTransformDisplay2 object)

GridVisible property (AudioTransformDisplay2 object)

Gets or sets a flag of grid visibility.

Property type

A Boolean value.

Syntax

object.GridVisible [= value]

The GridVisible property syntax has these parts:

Part | Type | Description
object | AudioTransformDisplay2 | An expression evaluating to an object.
value | Boolean | Flag of grid visibility. Can be true (grid is visible) or false (grid is invisible).

Example:

' VB sample where Display is an AudioTransformDisplay2 object and AudioFile1 is an AudioFile2 object.
Display.BackColor = System.Drawing.Color.Gray
Display.BorderColor = System.Drawing.Color.Gray
Display.BorderStyle = bSingle
Display.Color = System.Drawing.Color.Black
Display.GridColor = System.Drawing.Color.White
Display.GridVisible = True
Display.LogScale = False
Display.ScaleColor = System.Drawing.Color.Green
Display.ScaleFont = New System.Drawing.Font("Times", 36, FontStyle.Bold)
Display.ScaleXCaption = "Hz"
Display.ScaleXMax = 20000
Display.ScaleXMin = 20
Display.ScaleXVisible = True
Display.ScaleYCaption = "dB"
Display.ScaleYMax = 15
Display.ScaleYMin = -15
Display.ScaleYVisible = True
Display.TextColor = System.Drawing.Color.Blue
Display.PointColor = System.Drawing.Color.Pink

See Also:

GridColor

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


LineArraySize property (AudioTransformDisplay2 object)

LineArraySize property (AudioTransformDisplay2 object)

Gets or sets the size of the array get by GetLineArray method.

Property type

A Long value.

Syntax

object.LineArraySize [= value]

The LineArraySize property syntax has these parts:

Part | Type | Description
object | AudioTransformDisplay2 | An expression evaluating to an object.
value | Long | The array size.

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
'AudioTransformDisplay is an AudioTransformDisplay2 object
Dim FFTArray() As Single
Dim i As Integer
FFTArray = AudioTransformDisplay.GetLineArray
For i = 0 To AudioTransformDisplay.LineArraySize - 1
FFTArray(i) = 10 ^ (FFTArray(i) / 20)
Next i
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.FFTFilter LChannel(), FFTArray()
AudioTransform21.FFTFilter RChannel(), FFTArray()
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

SplineSteepnes | SplineType

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


LogScale property (AudioTransformDisplay2 object)

LogScale property (AudioTransformDisplay2 object)

Gets or sets a flag indicating if horizontal scale is logarithmic or not.

Property type

A Boolean value.

Syntax

object.LogScale [= value]

The LogScale property syntax has these parts:

Part | Type | Description
object | AudioTransformDisplay2 | An expression evaluating to an object.
value | Boolean | True if scale is logarithmic, otherwise - False.

Example:

' VB sample where Display is an AudioTransformDisplay2 object and AudioFile1 is an AudioFile2 object.
Display.BackColor = System.Drawing.Color.Gray
Display.BorderColor = System.Drawing.Color.Gray
Display.BorderStyle = bSingle
Display.Color = System.Drawing.Color.Black
Display.GridColor = System.Drawing.Color.White
Display.GridVisible = True
Display.LogScale = False
Display.ScaleColor = System.Drawing.Color.Green
Display.ScaleFont = New System.Drawing.Font("Times", 36, FontStyle.Bold)
Display.ScaleXCaption = "Hz"
Display.ScaleXMax = 20000
Display.ScaleXMin = 20
Display.ScaleXVisible = True
Display.ScaleYCaption = "dB"
Display.ScaleYMax = 15
Display.ScaleYMin = -15
Display.ScaleYVisible = True
Display.TextColor = System.Drawing.Color.Blue
Display.PointColor = System.Drawing.Color.Pink

See Also:

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


PointColor property (AudioTransformDisplay2 object)

PointColor property (AudioTransformDisplay2 object)

Gets or sets RGB color of ticks using standard Windows palette.

Property type

A OLE_COLOR value.

Syntax

object.PointColor [= value]

The PointColor property syntax has these parts:

Part | Type | Description
object | AudioTransformDisplay2 | An expression evaluating to an object.
value | OLE_COLOR | Color of ticks.

Example:

' VB sample where Display is an AudioTransformDisplay2 object and AudioFile1 is an AudioFile2 object.
Display.BackColor = System.Drawing.Color.Gray
Display.BorderColor = System.Drawing.Color.Gray
Display.BorderStyle = bSingle
Display.Color = System.Drawing.Color.Black
Display.GridColor = System.Drawing.Color.White
Display.GridVisible = True
Display.LogScale = False
Display.ScaleColor = System.Drawing.Color.Green
Display.ScaleFont = New System.Drawing.Font("Times", 36, FontStyle.Bold)
Display.ScaleXCaption = "Hz"
Display.ScaleXMax = 20000
Display.ScaleXMin = 20
Display.ScaleXVisible = True
Display.ScaleYCaption = "dB"
Display.ScaleYMax = 15
Display.ScaleYMin = -15
Display.ScaleYVisible = True
Display.TextColor = System.Drawing.Color.Blue
Display.PointColor = System.Drawing.Color.Pink

See Also:

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


ScaleColor property (AudioTransformDisplay2 object)

ScaleColor property (AudioTransformDisplay2 object)

Gets or sets RGB color of the scale using standard Windows palette.

Property type

A OLE_COLOR value.

Syntax

object.ScaleColor [= value]

The ScaleColor property syntax has these parts:

Part | Type | Description
object | AudioTransformDisplay2 | An expression evaluating to an object.
value | OLE_COLOR | Color type.

Example:

' VB sample where Display is an AudioTransformDisplay2 object and AudioFile1 is an AudioFile2 object.
Display.BackColor = System.Drawing.Color.Gray
Display.BorderColor = System.Drawing.Color.Gray
Display.BorderStyle = bSingle
Display.Color = System.Drawing.Color.Black
Display.GridColor = System.Drawing.Color.White
Display.GridVisible = True
Display.LogScale = False
Display.ScaleColor = System.Drawing.Color.Green
Display.ScaleFont = New System.Drawing.Font("Times", 36, FontStyle.Bold)
Display.ScaleXCaption = "Hz"
Display.ScaleXMax = 20000
Display.ScaleXMin = 20
Display.ScaleXVisible = True
Display.ScaleYCaption = "dB"
Display.ScaleYMax = 15
Display.ScaleYMin = -15
Display.ScaleYVisible = True
Display.TextColor = System.Drawing.Color.Blue
Display.PointColor = System.Drawing.Color.Pink

See Also:

ScaleFont | ScaleXCaption | ScaleXMax | ScaleXMin | ScaleXVisible | ScaleYCaption | ScaleYMax | ScaleYMin | ScaleYVisible

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


ScaleFont property (AudioTransformDisplay2 object)

ScaleFont property (AudioTransformDisplay2 object)

Gets or sets the font of the scale using standard Windows fonts.

Property type

A IFontDisp value.

Syntax

object.ScaleFont [= value]

The ScaleFont property syntax has these parts:

Part | Type | Description
object | AudioTransformDisplay2 | An expression evaluating to an object.
value | IFontDisp | The type of font.

Example:

' VB sample where Display is an AudioTransformDisplay2 object and AudioFile1 is an AudioFile2 object.
Display.BackColor = System.Drawing.Color.Gray
Display.BorderColor = System.Drawing.Color.Gray
Display.BorderStyle = bSingle
Display.Color = System.Drawing.Color.Black
Display.GridColor = System.Drawing.Color.White
Display.GridVisible = True
Display.LogScale = False
Display.ScaleColor = System.Drawing.Color.Green
Display.ScaleFont = New System.Drawing.Font("Times", 36, FontStyle.Bold)
Display.ScaleXCaption = "Hz"
Display.ScaleXMax = 20000
Display.ScaleXMin = 20
Display.ScaleXVisible = True
Display.ScaleYCaption = "dB"
Display.ScaleYMax = 15
Display.ScaleYMin = -15
Display.ScaleYVisible = True
Display.TextColor = System.Drawing.Color.Blue
Display.PointColor = System.Drawing.Color.Pink

See Also:

ScaleColor | ScaleXCaption | ScaleXMax | ScaleXMin | ScaleXVisible | ScaleYCaption | ScaleYMax | ScaleYMin | ScaleYVisible

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


ScaleXCaption property (AudioTransformDisplay2 object)

ScaleXCaption property (AudioTransformDisplay2 object)

Gets or sets the caption of the horizontal scale.

Property type

A String value.

Syntax

object.ScaleXCaption [= value]

The ScaleXCaption property syntax has these parts:

Part | Type | Description
object | AudioTransformDisplay2 | An expression evaluating to an object.
value | String | The caption string.

Example:

' VB sample where Display is an AudioTransformDisplay2 object and AudioFile1 is an AudioFile2 object.
Display.BackColor = System.Drawing.Color.Gray
Display.BorderColor = System.Drawing.Color.Gray
Display.BorderStyle = bSingle
Display.Color = System.Drawing.Color.Black
Display.GridColor = System.Drawing.Color.White
Display.GridVisible = True
Display.LogScale = False
Display.ScaleColor = System.Drawing.Color.Green
Display.ScaleFont = New System.Drawing.Font("Times", 36, FontStyle.Bold)
Display.ScaleXCaption = "Hz"
Display.ScaleXMax = 20000
Display.ScaleXMin = 20
Display.ScaleXVisible = True
Display.ScaleYCaption = "dB"
Display.ScaleYMax = 15
Display.ScaleYMin = -15
Display.ScaleYVisible = True
Display.TextColor = System.Drawing.Color.Blue
Display.PointColor = System.Drawing.Color.Pink

See Also:

ScaleColor | ScaleFont | ScaleXMax | ScaleXMin | ScaleXVisible | ScaleYCaption | ScaleYMax | ScaleYMin | ScaleYVisible

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


ScaleXMax property (AudioTransformDisplay2 object)

ScaleXMax property (AudioTransformDisplay2 object)

Gets or sets the maximum value of the horizontal scale.

Property type

A float value.

Syntax

object.ScaleXMax [= value]

The ScaleXMax property syntax has these parts:

Part | Type | Description
object | AudioTransformDisplay2 | An expression evaluating to an object.
value | float | The maximum value of the horizontal scale in hertz.

Example:

' VB sample where Display is an AudioTransformDisplay2 object and AudioFile1 is an AudioFile2 object.
Display.BackColor = System.Drawing.Color.Gray
Display.BorderColor = System.Drawing.Color.Gray
Display.BorderStyle = bSingle
Display.Color = System.Drawing.Color.Black
Display.GridColor = System.Drawing.Color.White
Display.GridVisible = True
Display.LogScale = False
Display.ScaleColor = System.Drawing.Color.Green
Display.ScaleFont = New System.Drawing.Font("Times", 36, FontStyle.Bold)
Display.ScaleXCaption = "Hz"
Display.ScaleXMax = 20000
Display.ScaleXMin = 20
Display.ScaleXVisible = True
Display.ScaleYCaption = "dB"
Display.ScaleYMax = 15
Display.ScaleYMin = -15
Display.ScaleYVisible = True
Display.TextColor = System.Drawing.Color.Blue
Display.PointColor = System.Drawing.Color.Pink

See Also:

ScaleColor | ScaleFont | ScaleXCaption | ScaleXMin | ScaleXVisible | ScaleYCaption | ScaleYMax | ScaleYMin | ScaleYVisible

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


ScaleXMin property (AudioTransformDisplay2 object)

ScaleXMin property (AudioTransformDisplay2 object)

Gets or sets the minimum value of the horizontal scale.

Property type

A float value.

Syntax

object.ScaleXMin [= value]

The ScaleXMin property syntax has these parts:

Part | Type | Description
object | AudioTransformDisplay2 | An expression evaluating to an object.
value | float | The minimum value of the horizontal scale in hertz.

Example:

' VB sample where Display is an AudioTransformDisplay2 object and AudioFile1 is an AudioFile2 object.
Display.BackColor = System.Drawing.Color.Gray
Display.BorderColor = System.Drawing.Color.Gray
Display.BorderStyle = bSingle
Display.Color = System.Drawing.Color.Black
Display.GridColor = System.Drawing.Color.White
Display.GridVisible = True
Display.LogScale = False
Display.ScaleColor = System.Drawing.Color.Green
Display.ScaleFont = New System.Drawing.Font("Times", 36, FontStyle.Bold)
Display.ScaleXCaption = "Hz"
Display.ScaleXMax = 20000
Display.ScaleXMin = 20
Display.ScaleXVisible = True
Display.ScaleYCaption = "dB"
Display.ScaleYMax = 15
Display.ScaleYMin = -15
Display.ScaleYVisible = True
Display.TextColor = System.Drawing.Color.Blue
Display.PointColor = System.Drawing.Color.Pink

See Also:

ScaleColor | ScaleFont | ScaleXCaption | ScaleXMax | ScaleXVisible | ScaleYCaption | ScaleYMax | ScaleYMin | ScaleYVisible

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


ScaleXVisible property (AudioTransformDisplay2 object)

ScaleXVisible property (AudioTransformDisplay2 object)

Gets or sets a flag of the horizontal scale visibility.

Property type

A Boolean value.

Syntax

object.ScaleXVisible [= value]

The ScaleXVisible property syntax has these parts:

Part | Type | Description
object | AudioTransformDisplay2 | An expression evaluating to an object.
value | Boolean | Flag of the horizontal scale visibility. Can be True (scale X is visible) or False (scale X is invisible).

Example:

' VB sample where Display is an AudioTransformDisplay2 object and AudioFile1 is an AudioFile2 object.
Display.BackColor = System.Drawing.Color.Gray
Display.BorderColor = System.Drawing.Color.Gray
Display.BorderStyle = bSingle
Display.Color = System.Drawing.Color.Black
Display.GridColor = System.Drawing.Color.White
Display.GridVisible = True
Display.LogScale = False
Display.ScaleColor = System.Drawing.Color.Green
Display.ScaleFont = New System.Drawing.Font("Times", 36, FontStyle.Bold)
Display.ScaleXCaption = "Hz"
Display.ScaleXMax = 20000
Display.ScaleXMin = 20
Display.ScaleXVisible = True
Display.ScaleYCaption = "dB"
Display.ScaleYMax = 15
Display.ScaleYMin = -15
Display.ScaleYVisible = True
Display.TextColor = System.Drawing.Color.Blue
Display.PointColor = System.Drawing.Color.Pink

See Also:

ScaleColor | ScaleFont | ScaleXCaption | ScaleXMax | ScaleXMin | ScaleYCaption | ScaleYMax | ScaleYMin | ScaleYVisible

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


ScaleYCaption property (AudioTransformDisplay2 object)

ScaleYCaption property (AudioTransformDisplay2 object)

Gets or sets the caption of the vertical scale.

Property type

A String value.

Syntax

object.ScaleYCaption [= value]

The ScaleYCaption property syntax has these parts:

Part | Type | Description
object | AudioTransformDisplay2 | An expression evaluating to an object.
value | String | The caption string.

Example:

' VB sample where Display is an AudioTransformDisplay2 object and AudioFile1 is an AudioFile2 object.
Display.BackColor = System.Drawing.Color.Gray
Display.BorderColor = System.Drawing.Color.Gray
Display.BorderStyle = bSingle
Display.Color = System.Drawing.Color.Black
Display.GridColor = System.Drawing.Color.White
Display.GridVisible = True
Display.LogScale = False
Display.ScaleColor = System.Drawing.Color.Green
Display.ScaleFont = New System.Drawing.Font("Times", 36, FontStyle.Bold)
Display.ScaleXCaption = "Hz"
Display.ScaleXMax = 20000
Display.ScaleXMin = 20
Display.ScaleXVisible = True
Display.ScaleYCaption = "dB"
Display.ScaleYMax = 15
Display.ScaleYMin = -15
Display.ScaleYVisible = True
Display.TextColor = System.Drawing.Color.Blue
Display.PointColor = System.Drawing.Color.Pink

See Also:

ScaleColor | ScaleFont | ScaleXCaption | ScaleXMax | ScaleXMin | ScaleXVisible | ScaleYMax | ScaleYMin | ScaleYVisible

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


ScaleYMax property (AudioTransformDisplay2 object)

ScaleYMax property (AudioTransformDisplay2 object)

Gets or sets the maximum value of the vertical scale.

Property type

A float value.

Syntax

object.ScaleYMax [= value]

The ScaleYMax property syntax has these parts:

Part | Type | Description
object | AudioTransformDisplay2 | An expression evaluating to an object.
value | float | The maximum value of the vertical scale in db.

Example:

' VB sample where Display is an AudioTransformDisplay2 object and AudioFile1 is an AudioFile2 object.
Display.BackColor = System.Drawing.Color.Gray
Display.BorderColor = System.Drawing.Color.Gray
Display.BorderStyle = bSingle
Display.Color = System.Drawing.Color.Black
Display.GridColor = System.Drawing.Color.White
Display.GridVisible = True
Display.LogScale = False
Display.ScaleColor = System.Drawing.Color.Green
Display.ScaleFont = New System.Drawing.Font("Times", 36, FontStyle.Bold)
Display.ScaleXCaption = "Hz"
Display.ScaleXMax = 20000
Display.ScaleXMin = 20
Display.ScaleXVisible = True
Display.ScaleYCaption = "dB"
Display.ScaleYMax = 15
Display.ScaleYMin = -15
Display.ScaleYVisible = True
Display.TextColor = System.Drawing.Color.Blue
Display.PointColor = System.Drawing.Color.Pink

See Also:

ScaleColor | ScaleFont | ScaleXCaption | ScaleXMax | ScaleXMin | ScaleXVisible | ScaleYCaption | ScaleYMin | ScaleYVisible

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


ScaleYMin property (AudioTransformDisplay2 object)

ScaleYMin property (AudioTransformDisplay2 object)

Gets or sets the minimum value of the vertical scale.

Property type

A float value.

Syntax

object.ScaleYMin [= value]

The ScaleYMin property syntax has these parts:

Part | Type | Description
object | AudioTransformDisplay2 | An expression evaluating to an object.
value | float | The minimum value of the vertical scale in db.

Example:

' VB sample where Display is an AudioTransformDisplay2 object and AudioFile1 is an AudioFile2 object.
Display.BackColor = System.Drawing.Color.Gray
Display.BorderColor = System.Drawing.Color.Gray
Display.BorderStyle = bSingle
Display.Color = System.Drawing.Color.Black
Display.GridColor = System.Drawing.Color.White
Display.GridVisible = True
Display.LogScale = False
Display.ScaleColor = System.Drawing.Color.Green
Display.ScaleFont = New System.Drawing.Font("Times", 36, FontStyle.Bold)
Display.ScaleXCaption = "Hz"
Display.ScaleXMax = 20000
Display.ScaleXMin = 20
Display.ScaleXVisible = True
Display.ScaleYCaption = "dB"
Display.ScaleYMax = 15
Display.ScaleYMin = -15
Display.ScaleYVisible = True
Display.TextColor = System.Drawing.Color.Blue
Display.PointColor = System.Drawing.Color.Pink

See Also:

ScaleColor | ScaleFont | ScaleXCaption | ScaleXMax | ScaleXMin | ScaleXVisible | ScaleYCaption | ScaleYMax | ScaleYVisible

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


ScaleYVisible property (AudioTransformDisplay2 object)

ScaleYVisible property (AudioTransformDisplay2 object)

Gets or sets a flag of the vertical scale visibility.

Property type

A Boolean value.

Syntax

object.ScaleYVisible [= value]

The ScaleYVisible property syntax has these parts:

Part | Type | Description
object | AudioTransformDisplay2 | An expression evaluating to an object.
value | Boolean | Flag of the vertical scale visibility. Can be True (scale Y is visible) or False (scale Y is invisible).

Example:

' VB sample where Display is an AudioTransformDisplay2 object and AudioFile1 is an AudioFile2 object.
Display.BackColor = System.Drawing.Color.Gray
Display.BorderColor = System.Drawing.Color.Gray
Display.BorderStyle = bSingle
Display.Color = System.Drawing.Color.Black
Display.GridColor = System.Drawing.Color.White
Display.GridVisible = True
Display.LogScale = False
Display.ScaleColor = System.Drawing.Color.Green
Display.ScaleFont = New System.Drawing.Font("Times", 36, FontStyle.Bold)
Display.ScaleXCaption = "Hz"
Display.ScaleXMax = 20000
Display.ScaleXMin = 20
Display.ScaleXVisible = True
Display.ScaleYCaption = "dB"
Display.ScaleYMax = 15
Display.ScaleYMin = -15
Display.ScaleYVisible = True
Display.TextColor = System.Drawing.Color.Blue
Display.PointColor = System.Drawing.Color.Pink

See Also:

ScaleColor | ScaleFont | ScaleXCaption | ScaleXMax | ScaleXMin | ScaleXVisible | ScaleYCaption | ScaleYMax | ScaleYMin

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


SplineSteepnes property (AudioTransformDisplay2 object)

SplineSteepnes property (AudioTransformDisplay2 object)

Gets or sets the steepness of the spline.

Property type

A Long value.

Syntax

object.SplineSteepnes [= value]

The SplineSteepnes property syntax has these parts:

Part | Type | Description
object | AudioTransformDisplay2 | An expression evaluating to an object.
value | Long | The spline steepness. Varies from 2 to 64.

See Also:

LineArraySize | SplineType

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


SplineType property (AudioTransformDisplay2 object)

SplineType property (AudioTransformDisplay2 object)

Gets or sets the type of the spline.

Property type

A SplineTypeConstants value.

Syntax

object.SplineType [= value]

The SplineType property syntax has these parts:

Part | Type | Description
object | AudioTransformDisplay2 | An expression evaluating to an object.
value | SplineTypeConstants | The type of the spline.

See Also:

LineArraySize | SplineSteepnes

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


TextColor property (AudioTransformDisplay2 object)

TextColor property (AudioTransformDisplay2 object)

Gets or sets RGB color of the text using standard Windows palette.

Property type

A OLE_COLOR value.

Syntax

object.TextColor [= value]

The TextColor property syntax has these parts:

Part | Type | Description
object | AudioTransformDisplay2 | An expression evaluating to an object.
value | OLE_COLOR | Color type.

Example:

' VB sample where Display is an AudioTransformDisplay2 object and AudioFile1 is an AudioFile2 object.
Display.BackColor = System.Drawing.Color.Gray
Display.BorderColor = System.Drawing.Color.Gray
Display.BorderStyle = bSingle
Display.Color = System.Drawing.Color.Black
Display.GridColor = System.Drawing.Color.White
Display.GridVisible = True
Display.LogScale = False
Display.ScaleColor = System.Drawing.Color.Green
Display.ScaleFont = New System.Drawing.Font("Times", 36, FontStyle.Bold)
Display.ScaleXCaption = "Hz"
Display.ScaleXMax = 20000
Display.ScaleXMin = 20
Display.ScaleXVisible = True
Display.ScaleYCaption = "dB"
Display.ScaleYMax = 15
Display.ScaleYMin = -15
Display.ScaleYVisible = True
Display.TextColor = System.Drawing.Color.Blue
Display.PointColor = System.Drawing.Color.Pink

See Also:

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


AudioTransformDisplay2 methods

AudioTransformDisplay2 methods

Method | Description
GetLineArray | Gets the array of the points of the line created by spline-interpolation from the tick points array.
GetPointArray | Gets the array of tick values.
MouseXToScaleX | Converts horizontal mouse pointer coordinate to the horizontal scale coordinate.
MouseYToScaleY | Converts vertical mouse pointer coordinate to the vertical scale coordinate.
Register | Enters user name and registration password to disable About window.
SetPoint | Sets the value of Index tick to the (Param1, Param2) value.
SetPointArray | Sets the array of the ticks.


GetLineArray method

GetLineArray method (AudioTransformDisplay2 object)

Gets the array of the points of the line created by spline-interpolation from the tick points array.

Return Type

A Float() value.

Syntax

LineArray = object.GetLineArray()

The GetLineArray method syntax has these parts:

Part | Type | Description
object | AudioTransformDisplay2 | An expression evaluating to an object.
LineArray | Float() | The array of line points.

Example:

' VB sample where AudioTransform21 is an AudioTransform2 object and AudioFile1 is an AudioFile2 object.
'AudioTransformDisplay is an AudioTransformDisplay2 object
Dim FFTArray() As Single
Dim i As Integer
FFTArray = AudioTransformDisplay.GetLineArray
For i = 0 To AudioTransformDisplay.LineArraySize - 1
FFTArray(i) = 10 ^ (FFTArray(i) / 20)
Next i
AudioFile1.OpenFile InpFile
Channel() = AudioFile1.ReadFile(nSamples)
If AudioFile1.nChannels = MONO Then
   Channel() = AudioTransform21.MakeStereoFromMono(Channel())
End If
LChannel() = AudioTransform21.GetLeftStereoChannel(Channel())
RChannel() = AudioTransform21.GetRightStereoChannel(Channel())
AudioTransform21.FFTFilter LChannel(), FFTArray()
AudioTransform21.FFTFilter RChannel(), FFTArray()
Channel() = AudioTransform21.MakeStereoFromArrays(LChannel(), RChannel())
AudioFile1.CloseFile

See Also:

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


GetPointArray method

GetPointArray method (AudioTransformDisplay2 object)

Gets the array of tick values.

Return Type

A Float() value.

Syntax

TickArray = object.GetPointArray()

The GetPointArray method syntax has these parts:

Part | Type | Description
object | AudioTransformDisplay2 | An expression evaluating to an object.
TickArray | Float() | The array of tick values.

Remarks:

The GetLineArray method creates the array of line points interpolated from ticks.

See Also:

SetPoint | SetPointArray

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


MouseXToScaleX method

MouseXToScaleX method (AudioTransformDisplay2 object)

Converts horizontal mouse pointer coordinate to the horizontal scale coordinate.

Return Type

A float value.

Syntax

ScaleX = object.MouseXToScaleX(MouseX As Long)

The MouseXToScaleX method syntax has these parts:

Part | Type | Description
object | AudioTransformDisplay2 | An expression evaluating to an object.
MouseX | Long | Horizontal mouse pointer coordinate.
ScaleX | Long | Horizontal coordinate on the scale.

See Also:

MouseYToScaleY

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


MouseYToScaleY method

MouseYToScaleY method (AudioTransformDisplay2 object)

Converts vertical mouse pointer coordinate to the vertical scale coordinate.

Return Type

A float value.

Syntax

ScaleY = object.MouseYToScaleY(MouseY As Long)

The MouseYToScaleY method syntax has these parts:

Part | Type | Description
object | AudioTransformDisplay2 | An expression evaluating to an object.
MouseY | Long | Vertical mouse pointer coordinate.
ScaleY | Long | Vertical coordinate on the scale.

See Also:

MouseXToScaleX

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


Register method

Register method (AudioTransformDisplay2 object)

Enters user name and registration password to disable About window.

Syntax

object.Register(bstrUser As String, bstrPassword As String)

The Register method syntax has these parts:

Part | Type | Description
object | AudioTransformDisplay2 | An expression evaluating to an object.
bstrUser | String | User name. You get a registration user name after the registration.
bstrPassword | String | Password string. You get a registration password after the registration.

Example:

' VB sample where TransformDisplay is AudioTransformDisplay2 objects.
TransformDisplay.Register "****", "****"

See Also:

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


SetPoint method

SetPoint method (AudioTransformDisplay2 object)

Sets the value of Index tick to the (Param1, Param2) value.

Syntax

object.SetPoint(Index As Long, Param1 As float, Param2 As float)

The SetPoint method syntax has these parts:

Part | Type | Description
object | AudioTransformDisplay2 | An expression evaluating to an object.
Index | Long | The number of tick.
Param1 | float | Horizontal value of tick.
Param2 | float | Vertical value of tick.

See Also:

GetPointArray | SetPointArray

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


SetPointArray method

SetPointArray method (AudioTransformDisplay2 object)

Sets the array of the ticks.

Syntax

object.SetPointArray(Array As Float())

The SetPointArray method syntax has these parts:

Part | Type | Description
object | AudioTransformDisplay2 | An expression evaluating to an object.
Array | Float() | The array with new values of ticks.

Remarks:

The GetLineArray method creates the array of line points interpolated from ticks.

See Also:

GetPointArray | SetPoint

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


AudioTransformDisplay2 events

AudioTransformDisplay2 events

Event | Description
MouseClick | Occurs when the user clicks the left mouse button.
MouseDblClick | Occurs when the user clicks the left mouse button twice.
MouseDown | Occurs when the user presses the left mouse button.
MouseMove | Occurs when the user moves the mouse.
MouseUp | Occurs when the user releases the left mouse button.
ResetPoint | Occurs when the tick point is changed.


MouseClick event

MouseClick event (AudioTransformDisplay2 object)

Occurs when the user clicks the left mouse button.

Syntax

Sub object_MouseClick(X As Long, Y As Long)

The MouseClick event syntax has these named arguments:

Part | Type | Description
X | Long | X coordinate of mouse pointer.
Y | Long | Y coordinate of mouse pointer.

Example:

'VB sample where AudioTransformDisplay21 is an AudioTransformDisplay2 object.
Private Sub AudioTransformDisplay21_MouseClick(ByVal X As Long, ByVal Y As Long)
lMousePos.Caption = AudioTransformDisplay21.MouseXToScaleX(X) & _
AudioTransformDisplay21.ScaleXCaption & "-->" & _
AudioTransformDisplay21.MouseYToScaleY(Y) & _
AudioTransformDisplay21.ScaleYCaption
End Sub

See Also:

MouseDblClick | MouseDown | MouseMove | MouseUp | ResetPoint

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


MouseDblClick event

MouseDblClick event (AudioTransformDisplay2 object)

Occurs when the user clicks the left mouse button twice.

Syntax

Sub object_MouseDblClick()

Example:

'VB sample where AudioTransformDisplay21 is an AudioTransformDisplay2 object.
Private Sub AudioTransformDisplay21_MouseMove()
MsgBox "Sets points"
End Sub

See Also:

MouseClick | MouseDown | MouseMove | MouseUp | ResetPoint

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


MouseDown event

MouseDown event (AudioTransformDisplay2 object)

Occurs when the user presses the left mouse button.

Syntax

Sub object_MouseDown(X As Long, Y As Long)

The MouseDown event syntax has these named arguments:

Part | Type | Description
X | Long | X coordinate of mouse pointer.
Y | Long | Y coordinate of mouse pointer.

Example:

'VB sample where AudioTransformDisplay21 is an AudioTransformDisplay2 object.
Private Sub AudioTransformDisplay21_MouseMove(ByVal X As Long, ByVal Y As Long)
lMousePos.Caption = AudioTransformDisplay21.MouseXToScaleX(X) & _
AudioTransformDisplay21.ScaleXCaption & "-->" & _
AudioTransformDisplay21.MouseYToScaleY(Y) & _
AudioTransformDisplay21.ScaleYCaption
End Sub

See Also:

MouseClick | MouseDblClick | MouseMove | MouseUp | ResetPoint

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


MouseMove event

MouseMove event (AudioTransformDisplay2 object)

Occurs when the user moves the mouse.

Syntax

Sub object_MouseMove(X As Long, Y As Long)

The MouseMove event syntax has these named arguments:

Part | Type | Description
X | Long | X coordinate of mouse pointer.
Y | Long | Y coordinate of mouse pointer.

Example:

'VB sample where AudioTransformDisplay21 is an AudioTransformDisplay2 object.
Private Sub AudioTransformDisplay21_MouseDown(ByVal X As Long, ByVal Y As Long)
lMousePos.Caption = AudioTransformDisplay21.MouseXToScaleX(X) & _
AudioTransformDisplay21.ScaleXCaption & "-->" & _
AudioTransformDisplay21.MouseYToScaleY(Y) & _
AudioTransformDisplay21.ScaleYCaption
End Sub

See Also:

MouseClick | MouseDblClick | MouseDown | MouseUp | ResetPoint

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


MouseUp event

MouseUp event (AudioTransformDisplay2 object)

Occurs when the user releases the left mouse button.

Syntax

Sub object_MouseUp(X As Long, Y As Long)

The MouseUp event syntax has these named arguments:

Part | Type | Description
X | Long | X coordinate of mouse pointer.
Y | Long | Y coordinate of mouse pointer.

Example:

'VB sample where AudioTransformDisplay21 is an AudioTransformDisplay2 object.
Private Sub AudioTransformDisplay21_MouseUp(ByVal X As Long, ByVal Y As Long)
lMousePos.Caption = AudioTransformDisplay21.MouseXToScaleX(X) & _
AudioTransformDisplay21.ScaleXCaption & "-->" & _
AudioTransformDisplay21.MouseYToScaleY(Y) & _
AudioTransformDisplay21.ScaleYCaption
End Sub

See Also:

MouseClick | MouseDblClick | MouseDown | MouseMove | ResetPoint

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


ResetPoint event

ResetPoint event (AudioTransformDisplay2 object)

Occurs when the tick point is changed.

Syntax

Sub object_ResetPoint(TickIndex As Long)

The ResetPoint event syntax has these named arguments:

Part | Type | Description
TickIndex | Long | The number of tick.

See Also:

MouseClick | MouseDblClick | MouseDown | MouseMove | MouseUp

Applies to: AudioTransformDisplay2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


NCTAudioTransform2 constants

NCTAudioTransform2 constants

Constants | Description
BorderTypeConstants | These are the constants for the BorderStyle property.
ChannelsConstants | These are the constants for the ArrayChannels property (AudioTransform2 object).
ErrorConstants | These are the constants for the LastErrorNum property.
FrequencyConstants | These are the constants for the ArrayFrequency property.
SplineTypeConstants | These are the constants for the SplineType property.


BorderTypeConstants enumeration

BorderTypeConstants enumeration

These are the constants for the BorderStyle property.

Members

Part | Value | Description
bNone | 0 | Border is absent.
bSingle | 1 | Border is single.
bLowered | 2 | Border is lowered.
bRaised | 3 | Border is raised.

Remarks:

Example:

See Also:

Applies to: BorderTypeConstants

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


ChannelsConstants enumeration

ChannelsConstants enumeration

These are the constants for the ArrayChannels property (AudioTransform2 object).

Members

Part | Description
MONO | 1
STEREO | 2

Remarks:

Example:

See Also:

Applies to: ChannelsConstants

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


ErrorConstants enumeration

ErrorConstants enumeration

These are the constants for the LastErrorNum property.

Members

Part | Value | Description
NOERRORS | 0 | No errors.
BUSY | -10 | It is impossible to execute the current method because the application is busy by another one.
MEMORY | -11 | Memory error.
FORMATFILE | -12 | Wrong file format. It is an attempt to open a non-audio file as an audio file.
FORMATNOTSUPPORT | -13 | Unsupported audio file format. It is an attempt to open an unsupported audio file format.
OUTDRIVER | -14 | Output audio device error. For example: wrong device, audio device is already opened in your application or is in use by another one and many others… It hardly depends on hardware.
INPDRIVER | -15 | Input audio device error. . For example: wrong device, audio device is already opened in your application or is in use by another one and many others… It hardly depends on hardware.
MIXERDRIVER | -16 | Mixer device driver error.
ACMDRIVER | -17 | ACM driver error.
FILEACCESS | -18 | The specified file is already in use.
INVALIDOPERATION | -19 | Invalid operation. For example, you try to execute READ method before OPEN method.
INVALIDPARAM | -20 | Invalid parameters. You try to execute a method with invalid parameters.
ASPIDRIVER | -21 | Incorrect CD driver operation. ASPI driver returns an error.
CONTROLNOTINSTALLED | -22 | Control not installed.
INDEXOUTOFRANGE | -23 | Incorrect address to the array. Index out of the array range.
STREAM | -24 |
UNEXPECTED | -40 | Unexpected error.

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


FrequencyConstants enumeration

FrequencyConstants enumeration

These are the constants for the ArrayFrequency property.

Members

Part | Value | Description
FQ_96_KHZ | 96000 | 96000 hertz.
FQ_88_KHZ | 88200 | 88200 hertz.
FQ_48_KHZ | 48000 | 48000 hertz.
FQ_44_KHZ | 44100 | 44100 hertz.
FQ_32_KHZ | 32000 | 32000 hertz.
FQ_24_KHZ | 24000 | 24000 hertz.
FQ_22_KHZ | 22050 | 22050 hertz.
FQ_16_KHZ | 16000 | 16000 hertz.
FQ_12_KHZ | 12000 | 12000 hertz.
FQ_11_KHZ | 11025 | 11025 hertz.
FQ_8_KHZ | 8000 | 8000 hertz.
FQ_6_KHZ | 6000 | 6000 hertz.

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


SplineTypeConstants enumeration

SplineTypeConstants enumeration

These are the constants for the SplineType property.

Members

Part | Value | Description
stNone | 0 |
stOne | 1 |
stTwo | 2 |

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com


AvailPhysMemory property (AudioTransform2 object)

AvailPhysMemory property (AudioTransform2 object)

Read-only property that returns size of available physical operative memory in your system.

Property type

A Long value.

Syntax

object.AvailPhysMemory [= value]

The AvailPhysMemory property syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
value | Long | Memory is in bytes.

See Also:

Apples To: AudioTransform2

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT Company Ltd. http://www.nctsoft.com


FIRFilter method

NCTAudioCompress ActiveX DLL
FIRFilter method (AudioTransform2 object)

Applies Finite Impulse Response filter to the existing audio data array.

Syntax

object.FIRFilter(WavArray As Integer(), FreqArray As Float(), dbGainArray As Float(), WeightArray As Float(), Quality As Long)

The FIRFilter method syntax has these parts:

Part | Type | Description
object | AudioTransform2 | An expression evaluating to an object.
WavArray | Integer() | Audio data array.
FreqArray | Float() | The array of the frequency values of the filter, each value is in hertz.
dbGainArray | Float() | The array of the gain values of the filter, each value is in db.
WeightArray | Float() | The array of the weight values of the filter.
Quality | Long | The quality of the filter. Varies from 0 (10 points) to 100 (256 points). The more points is the better filter quality and most time for calculating.

Remarks:

The dimensions of FreqArray, dbGainArray, WeightArray arrays are equal. The FreqArray and dbGainArray arrays determine profile of filtering.

Example:

' VB sample where AudioTransform is an AudioTransform2 object.
' Starts operation "invert"
Dim Freq(4) As Single
Dim dbGain(4) As Single
Dim Weight(4) As Single

Freq(0) = 0
dbGain(0) = 1
Weight(0) = 1000

Freq(1) = 1000
dbGain(1) = 1
Weight(1) = 1000

Freq(2) = -1
dbGain(2) = -1
Weight(2) = -1

Freq(3) = 1100
dbGain(3) = 0
Weight(3) = 1000

Freq(4) = 22050
dbGain(4) = 0
Weight(4) = 1000

AudioTransform.FIRFilter LChannel(), Freq(), dbGain(), Weight(), 100
AudioTransform.FIRFilter RChannel(), Freq(), dbGain(), Weight(), 100

AudioTransform.Invert LChannel()
AudioTransform.Invert RChannel()

See Also:

BandPassFilter | FFTFilter | HighPassFilter | HighShelfFilter | LowPassFilter | LowShelfFilter | NotchFilter | PeakEQFilter

Applies to: AudioTransform2

Send Feedback on the NCTAudioCompress documentation.
NCTAudioCompress was developed by NCT company http://www.nctsoft.com


NCTAudioTransform2Lib

NCTAudioStudio2 ActiveX DLLs

Version 2.2

NCTAudioTransform2 ActiveX DLL is intended for processing and transforming audio data.

With NCTAudioTransform2 you can perform the following operations:

  • Amplify audio data

  • Insert time delay in audio array

  • Modulate audio array

  • Invert audio array

  • Reverse audio array

  • Mix two audio arrays

  • Perform FFT transform

  • Generate sine or noise array

  • Normalize audio data

  • Filtering audio data

  • Equalize audio data

  • Delete silence from audio array

  • Resample audio array

and many other...

NCTAudioTransform2 consists of the following objects:

  • AudioTransform2 - the main object for transforming.

  • AudioTransformDisplay2 - a complementary object for visual representation of creating the FFTArray array for FFTFilter method from the main object.

NCTAudioTransform2 is a part of the NCTAudioStudio2 package.

Send Feedback on the NCTAudioTransform2 documentation.
NCTAudioTransform2 was developed by NCT company http://www.nctsoft.com